Find the answer to your Linux question:
Results 1 to 3 of 3
Hi there, I've been struggling with this for ages, and cannot find a solution. I'm currently using an IBM x206 server, with two SATA hard drives. Originally, I had a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    2

    New hdd breaks bootup!


    Hi there, I've been struggling with this for ages, and cannot find a solution.

    I'm currently using an IBM x206 server, with two SATA hard drives. Originally, I had a dual boot system with windows xp and ubuntu 7.04 on a single drive. Recently, I bought a second western digital 160GB drive. It installed fine, I formated it to ext3 under ubuntu, and then installed ubuntu 7.04 to it.

    I used this system for a month or so, then tried to install FreeBSD to the new old hard drive. However, I'm guessing something must have gone wrong, as now my machine is unbootable. It will cylce through all the BIOS POST stuff, but then hangs with a non-flashing cursor at the top corner of the screen; no grub or anything. Removing the original hard drive booted Ubuntu, and removing my new hard drive booted FreeBSD.

    I have tried completely wiping the old hard drive from a grml livecd, using the command;

    dd if=/dev/zero of=/dev/sda

    However, this doesn't clear the error.

    Any advice would be really appreciated, I'm completely out of ideas!

  2. #2
    Just Joined! iyeru42's Avatar
    Join Date
    May 2007
    Location
    Madison, WI
    Posts
    13
    Did you make sure to write the MBR (Master Boot Record)? Because without that set, not even the WinXP Setup Disk will even try to detect the disk. Although, even with that... I still am having problems (See my other thread in this forum.)

    You can write the MBR with KNOPPIX (Using sudo testdisk command via the root user (type su when you load up the terminal).)

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    2

    Thumbs up

    Hi there, well I fixed the problem; even though I'd re-flashed my computers BIOS, i still needed to reset it. Once I did that, everything was fine and dandy.

    Still doesn't quiet explain why a new opperating system broke my bios, but never mind...

    Cheers!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •