Hello Linux gurus!

I'm having some trouble getting my Highpoint Rocketraid 454 to work in Debian 4.0. What it comes down to is that the kernel parameters hde=noprobe doesn't seem to work.

Here is my grub menu.lst file:
title Debian GNU/Linux, kernel 2.6.18-4-686
root (hd0,0)
kernel /boot/vmlinuz-2.6.18-4-686 root=/dev/hda1 ro hde=noprobe hdf=noprobe hdg=noprobe hdh=noprobe hdi=noprobe hdj=noprobe hdk=noprobe hdl=noprobe
initrd /boot/initrd.img-2.6.18-4-686

I have tried to move the "root=/dev/hda1 ro" to the end of the line, but that seems to make no difference.

What happens is that during boot it still probes the IDE drives. dmesg shows:
hde: Maxtor 6B200P0, ATA DISK drive
ide2 at 0xc400-0xc407,0xc002 on irq 169
Probing IDE interface ide3...
hdg: Maxtor 6Y200P0, ATA DISK drive
hdh: Maxtor 6B200P0, ATA DISK drive
ide3 at 0xbc00-0xbc07,0xb802 on irq 169
Probing IDE interface ide4...
hdi: Maxtor 6Y200P0, ATA DISK drive
hdj: ST3200822A, ATA DISK drive
ide4 at 0xdc00-0xdc07,0xd802 on irq 169
Probing IDE interface ide5...
hdk: Maxtor 6B200P0, ATA DISK drive
hdl: Maxtor 6B200P0, ATA DISK drive
ide5 at 0xd400-0xd407,0xd002 on irq 169

Maybe it does that even though I have specified in grub that it should not probe the IDE devices? In any case when the system has booted i run fdisk -l and it shows the IDE drives, at least 2-3 of them and then it hangs. If I send the reboot command it will say "hdj lost interrupt". What I want to see when I run fdisk -l are the 3 raid arrays I have setup in the BIOS on the hpt374 board. They are shown as scsi devices. Instead it shows, or tries to show, the IDE devices connected to the hpt374 board.

The hpt374 driver loads fine upon start up, I managed to get that working at least

Anyone have an idea what can be wrong? Let me know if you need more information. I'm a bit of a newbie, but I have no problem with the hpt374 on other distros. I have used it in Mandrake, Slackware, Red Hat, Suse and also earlier version of Debian with no problem.

Best Regards
Per.