Find the answer to your Linux question:
Results 1 to 6 of 6
My brother uses windows in the same pc, and there's a little bit of difference regarding the use of screen by both OSs. It's somewhat (or maybe precisely) as if ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214

    actual screen position differs between Windows and Linux [solved]


    My brother uses windows in the same pc, and there's a little bit of difference regarding the use of screen by both OSs. It's somewhat (or maybe precisely) as if each OS sets a slightly different position for where the image is going to be displayed.

    Anyone knows where could I adjust this thing, either on windows or linux in order to both make the same use of the screen area, so I don't need to adjust via hardware every time I'm going to use the computer after my brother uses (and vice-versa)?
    Last edited by the dsc; 07-04-2007 at 11:09 PM. Reason: adding "solved" tag

  2. #2
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    I've found the answer here:

    Adjusting display / screen position using xvidtune | languor.us

    Adjusting display / screen position using xvidtune
    Mon, 2007-05-21 08:39 — Jubal Harshaw

    Many moons ago, I had to run an update to the nVidia driver for my Kubuntu box. After installing it, I found that the next time I ran X, my display was offset by about 50px to the right. Normally, it would have been possible to fix this via the monitor, most of which have a convenient "auto" button to solve such issues. However, my set-up involves the use of a KVM switch, which allows me to use a single keyboard, mouse and monitor for more than one PC (four in my case). Ergo, I couldn't just click the auto button to sort this issue out as that would mean ruining the display on the other three systems. I was too lazy to search for a fix at the time, but I finally got annoyed enough to fix it last night.

    The fix goes as follows:
    Open up Konsole / your terminal of choice and navigate to /etc/X11.
    Back up your xorg.conf file : sudo cp xorg.conf xorg.conf.pre.xvidtune.
    Type sudo nano xorg.conf.
    Open up another Konsole terminal and type xvidtune. Read and heed the warning message.
    To make things easier at a later stage, note down all the values listed on a piece of paper or in a text editor.
    Use the left, right, up, down etc. buttons to adjust the display. Preferably, do this one click at a time and use the test button to check the results.
    The values that control horizontal alignment are HSyncStart and HsyncEnd. Similary, vertical positioning is controlled by VSyncStart and VsyncEnd respectively. HTotal and VTotal control width and height.
    Once you are satisfied with the display position, note down the values of the variables you have modified.
    Go back to the terminal where you are editing xorg.conf. Look for something like Section "Monitor" where you will find a ton of modeline listings.
    Look for the modeline pertaining to your current display resolution - for e.g. 1280x1024. Use the values from step 5 to isolate the correct line.
    Once you have the correct line, you will very likely not know which number to replace with the new variables. Again use the values from step 5 to narrow things down.
    Replace the values with the new values. For e.g., on my machine the original line was:
    modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync.
    After adjusting my display's horizontal position, the new line with new HSyncStart and HSyncEnd values looked like the following:
    modeline "1280x1024@60" 108.0 1280 1348 1460 1688 1024 1025 1028 1066 +hsync +vsync.
    Once this is done, save the file by pressing CTRL + X, close xvidtune and other applications and restart your display manager using CTRL + ALT + Backspace.
    Ideally, you will see your screen correctly positioned now. If you encounter any problems or require more information on xvidtune, type man xvidtune in a terminal to bring up the help page. If you would like to go back to the old configuration, use the backup file you created in step 2 to overwrite the current xorg.conf and restart your display manager again.

  3. #3
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    406
    Often, you don't need to go and specify an entire tweaked modeline. Usually, it's simply a matter of the vertical refresh rate being different. For example, it might be 75hz in Windows, but 60hz in Linux. If you change one of them to match the other, then the video signals may naturally sync up.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    Thanks. I got to try that since the solution I found has the side effect of the KDM screen becoming virtually bigger only after I exit fluxbox... for some reason...

  6. #5
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    Is there anything wrong with this:

    Code:
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	HorizSync	28-51
    	VertRefresh	43-60
      modeline  "1024x768@60" 65.0 1024 1064 1200 1348 768 771 777 806 -vsync -hsync
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"nVidia Corporation NV18 [GeForce4 MX 4000]"
    	Monitor		"Generic Monitor"
    	DefaultDepth	24
    	SubSection "Display"
    		Depth		1
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		4
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		8
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		15
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		16
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth		24
    		Modes		"1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    ... anything that would render null the parameters on the "modeline"?

    Because what's there is what I got from xvidtune's adjustments, but for some reason, when I restart X, the screen is still misplaced.

  7. #6
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    I've found what was the problem.

    In the "modeline" line, it was "1024x768@60". In the "screen" section, however, it was referring only to "1024x768", which is not set on the modeline. So it's solved either by removing the @60 on the modeline, or adding it to the "mode" lines.

    As I'm not sure whether it's just a label that one could write anything he wants, or if this "60" is a value set there and used somewhere else, I did the latter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •