Hi everyone

Linux Debian 2.6.18-4-686

trying to install Quantum DLT-V4 SATA Tape drive.

debian:/etc# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: QUANTUM Model: DLT-V4 Rev: 0800
Type: Sequential-Access ANSI SCSI revision: 02

debian:/# mt -f /dev/nst0 status
/dev/nst0: Input/output error


typical output from mt -f /dev/st0 looks like

ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1.00: configured for PIO0
ata1: EH complete
ata1.00: speed down requested but no transfer mode left
ata1.00: exception Emask 0x52 SAct 0x0 SErr 0xffffffff action 0x6
ata1.00: tag 0 cmd 0xa0 Emask 0x52 stat 0x51 err 0x50 (ATA bus error)
ata1: hard resetting port
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1.00: configured for PIO0
ata1: EH complete
ata1.00: speed down requested but no transfer mode left
ata1.00: exception Emask 0x52 SAct 0x0 SErr 0xffffffff action 0x6
ata1.00: tag 0 cmd 0xa0 Emask 0x52 stat 0x51 err 0x50 (ATA bus error)
ata1: hard resetting port
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1.00: configured for PIO0
ata1: EH complete
ata1.00: speed down requested but no transfer mode left
ata1.00: exception Emask 0x52 SAct 0x0 SErr 0xffffffff action 0x6
ata1.00: tag 0 cmd 0xa0 Emask 0x52 stat 0x51 err 0x50 (ATA bus error)
ata1: hard resetting port
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1.00: configured for PIO0
ata1: EH complete
ata1.00: speed down requested but no transfer mode left
ata1.00: exception Emask 0x52 SAct 0x0 SErr 0xffffffff action 0x6
ata1.00: tag 0 cmd 0xa0 Emask 0x52 stat 0x51 err 0x50 (ATA bus error)
ata1: hard resetting port
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1.00: configured for PIO0
ata1: EH complete

I can't work out what this means. Is it something to do with the SATA pretending to be SCSI ? Have I missed something in setting up the tape drive ?