Find the answer to your Linux question:
Results 1 to 2 of 2
I have a 56K software modem conected to my computer through AMR not PCI. now SuSE 9.1 detects this modem fine, and installis it fine so i can dial up, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790

    modem troubles


    I have a 56K software modem conected to my computer through AMR not PCI. now SuSE 9.1 detects this modem fine, and installis it fine so i can dial up, the problem comes when i try and restart the computer. a few services do not work on rebooting. The portmapper fails to start, the ssh daemon claims to start, but when typing rcsshd status tells me that it is 'unused' not 'running'.

    Also i have noticed that in the /dev folder there has appeared a /dev/null.current symlink which points to /dev/null.<date>

    I have tried reinstalling /dev/null, portmapper and sshd, but they STILL fail to load correctly at boot time.

    The modem still (when connecting) has a dial tone, and dials, but shortly after says no carrier.

    Has anyone had this problem before and solved it? or have any ideas as to where to look to solve this? has anyone heard of anything similar? This is confusing me.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    Location
    South Africa
    Posts
    8
    What does

    netstat -r

    print out?

    Do you have three entries something like this:

    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface
    169.254.255.0 * 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
    127.0.0.0 * 255.0.0.0 U 0 0 0 lo

    ?

    Sounds like the modem installation might have messed up your routing tables, and you now only have a rout to localhost - 127.0.0.0 - I don't know how to fix this, but you might try a routing faq. I have found that if I don't add my default gateway like this

    /sbin/route add default gw 169.254.255.100 netmask 0.0.0.0 eth0

    so that my routing table gets this added

    default Router 0.0.0.0 UG 0 0 0 eth0

    I have no internet functionality. You might have something similar?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •