Find the answer to your Linux question:
Results 1 to 4 of 4
Hey, I try to make the latest Gatos drm-kernel (2004-06-23) and it won't compile--I get make errors. Here's what I have: All-in-Wonder Radeon (the original, that's the exact name) RedHat9 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    6

    gatos drm-kernel won't compile! XFree86 4.3.0 kernel 2.4.20


    Hey,
    I try to make the latest Gatos drm-kernel (2004-06-23) and it won't compile--I get make errors.
    Here's what I have:
    All-in-Wonder Radeon (the original, that's the exact name)
    RedHat9
    Xfree86 4.3.0
    linux kernel 2.4.20
    Pentium 4 1.4GHz
    ABIT BD7II-RAID moboard
    512MB RAM
    I checked, and I'm DRI is running fine, and XFree86.log says Direct rendering is enabled.
    Here's the make output:

    # make -f Makefile.linux
    === KERNEL HEADERS IN /lib/modules/2.4.20-8/build/include
    === SMP=0 MODULES=1 MODVERSIONS=1 AGP=1
    === Compiling for machine i686
    === WARNING
    === WARNING Use 2.4.x kernels ONLY !
    === WARNING
    cc -O2 -pipe -fno-strict-aliasing -fno-common -Wall -Wwrite-strings -Wpointer-arith -Wcast-align -Wstrict-prototypes -Wnested-externs -Wpointer-arith -D__KERNEL__ -DMODULE -fomit-frame-pointer -fno-strict-aliasing -DCONFIG_AGP -DCONFIG_AGP_MODULE -DCONFIG_DRM_SIS -DMODVERSIONS -include /lib/modules/2.4.20-8/build/include/linux/modversions.h -DEXPORT_SYMTAB -I/lib/modules/2.4.20-8/build/include -c gamma_drv.c -o gamma_drv.o
    In file included from /lib/modules/2.4.20-8/build/include/linux/irq.h:69,
    from /lib/modules/2.4.20-8/build/include/asm/hardirq.h:6,
    from /lib/modules/2.4.20-8/build/include/linux/interrupt.h:46,
    from /lib/modules/2.4.20-8/build/include/asm/highmem.h:25,
    from /lib/modules/2.4.20-8/build/include/linux/highmem.h:11,
    from /lib/modules/2.4.20-8/build/include/linux/vmalloc.h:8,
    from /lib/modules/2.4.20-8/build/include/asm/io.h:47,
    from /lib/modules/2.4.20-8/build/include/asm/pci.h:35,
    from /lib/modules/2.4.20-8/build/include/linux/pci.h:657,
    from drmP.h:50,
    from gamma_drv.c:34:
    /lib/modules/2.4.20-8/build/include/asm/hw_irq.h: In function `x86_do_profile':
    /lib/modules/2.4.20-8/build/include/asm/hw_irq.h:195: warning: nested extern declaration of `prof_cpu_mask'
    /lib/modules/2.4.20-8/build/include/asm/hw_irq.h:196: warning: nested extern declaration of `_stext'
    In file included from /lib/modules/2.4.20-8/build/include/linux/vmalloc.h:8,
    from /lib/modules/2.4.20-8/build/include/asm/io.h:47,
    from /lib/modules/2.4.20-8/build/include/asm/pci.h:35,
    from /lib/modules/2.4.20-8/build/include/linux/pci.h:657,
    from drmP.h:50,
    from gamma_drv.c:34:
    /lib/modules/2.4.20-8/build/include/linux/highmem.h: In function `bh_kmap':
    /lib/modules/2.4.20-8/build/include/linux/highmem.h:20: warning: pointer of type `void *' used in arithmetic
    In file included from gamma_drv.c:54:
    drm_vm.h: In function `gamma_mmap':
    drm_vm.h:462: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
    drm_vm.h:462: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
    drm_vm.h:462: too few arguments to function `remap_page_range_R2baf18f2'
    make: *** [gamma_drv.o] Error 1

    #why!!!



    Oh yeah, and here's my display sections of XF86Config:

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "NEC MultiSync A500"
    DisplaySize 280 210
    HorizSync 31.0 - 65.0
    VertRefresh 60 #I set this to 60 for gatos tv output to work right
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "radeon"
    VendorName "Videocard vendor"
    BoardName "ATI Radeon All In Wonder AGP"
    VideoRam 32768
    Option "AGPMode" "4" #I added this line
    Option "AGPFastWrite" "yes" #added this too - uses dri modules
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It could be that RedHat has patched their production kernel so hard that you can't build Gatos against it. Try building and installing a vanilla kernel from kernel.org and see if you can compile Gatos against that.

  3. #3
    Just Joined!
    Join Date
    May 2004
    Posts
    6

    Sorry still recompiling kernel :)

    This is my first time. I got the newly-recompiled kernel to boot even though make modules_install had ac97 depmod errors. I'll work on it and hopefully fix it today.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2004
    Posts
    6

    Wow it worked w/ non-redhat kernel!

    Wow it worked w/ downloaded&compiled kernel 2.4.26!
    This was good to learn to recompile the kernel. Of course, however, it is rather ANNOYING that RedHat modded the kernel in such a way that my crap wouldn't compile.

    I have no more errors with building drm-kernel, thanks for the help.

    "Seacrest out",
    ProtoArmor

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •