I've searched and read about a hundred posts and replies and can't find exactly what I need.

I have tried doing a yum -y install after a download and there are just too many conflicts for the dependencies. I'm afraid to remove them (for instance, glibc 2.3.5... I don't know if the current system would reboot if I needed to.)

So, here's my situation and my question(s):

I have a fresh fc7 install on my home computer along with Windows XP. No problem double-booting.

I have a remote system currently with fc4 on it. It's fully operational.

I can sftp to it from my local fc7 install and login as root.

Bottom line question... how do I install my fc7 on top of, and replacing, the fc4 on the remote system?

I have set up a couple of methods and I'm just not confident that any of them will work properly. Here's a couple of them:

I have copied all of the fc7 files to the remote /boot directory to co-exist with the current fc4 images. The files I copied are:

config-2.6.21-1.3194.fc7
initrd-2.6.21-1.3194.fc7.img
System.map-2.6.21-1.3194.fc7
vmlinuz-2.6.21-1.3194.fc7
and the 'grub' directory and all its contents.

The grub.conf file contains:

default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.21-1.3194.fc7)
root (hd0,0)
kernel /vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.21-1.3194.fc7.img

If this is anywhere near correct, I don't know what to do next.

Here's another thing I've tried:

I've downloaded the fc7 release from redhat. The following files now exist in my remote /root directory:

anaconda-ks.cfg
fedora-release-notes-7.0.0-1.noarch.rpm
fedora-release-7-3.noarch.rpm
install.log
install.log.syslog
and the Desktop directory.

I modified and copied the .cfg file to "ks.cfg". It contains:

# Kickstart file automatically generated by anaconda.

install
*** I need the data that goes here. I have a floppy mounted and copied the ks.cfg file to it. ***
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8 en_US en en_US.UTF-8 en_US en
keyboard us
xconfig --card "ATI Radeon 7000" --videoram 16384 --hsync 30-96 --vsync 50-160 --resolution 800x600 --depth 16 --startxonboot --defaultdesktop gnome
network --device eth0 --bootproto static --ip xx.xxx.xxx.xxx --netmask 255.255.255.240 --gateway xx.xxx.xxx.xxx --nameserver xxx.xxx.x.x,xxx.xxx.x.x --hostname remote.com
network --device eth1 --bootproto dhcp --hostname remote.com
rootpw password
firewall --enabled --port=22:tcp --port=80:tcp --port=21:tcp --port=25:tcp
selinux --enforcing
authconfig --enableshadow --enablemd5
timezone America/Tijuana
bootloader --location=mbr --driveorder=sda --append="rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#clearpart --all --drives=sda
#part /boot --fstype ext3 --size=100 --ondisk=sda
#part pv.3 --size=0 --grow --ondisk=sda
#volgroup VolGroup00 --pesize=32768 pv.3
#logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
#logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=1000 --grow --maxsize=1984
followed by all the standard %packages contents of the original .cfg

I assure you, all of the 'xxx's in the above are correct, as is my host name and password.

As in the first example, if this is anywhere near correct, I don't know what to do next.

Any suggestions will be really, really appreciated!

Thanks!
Teresk