I am a Linux (Mandriva) newbie. I use a broadband client to connect to the Net in WinXP. I have been trying to install the same client in Mandriva so that I can connect to the Net but am encountering problems along the way & as a result am not being able to connect to the Net.

To install the client, 2 RPM packages named openssl0.9.7-0.9.7c-52922cl.i386.rpm & sify_bband-3.0-0.i386.rpm have to be downloaded after which the following 2 commands have to be executed in a terminal window as the root user (i.e. I have to be logged in as the root user):

rpm -ivh openssl0.9.7-0.9.7c-52922cl.i386.rpm

rpm -ivh sify_bband-3.0-0.i386.rpm


The first command, which has to be used to execute the OpenSSL (needed by the client), gets executed without any errors but the second command, which is needed to execute the broadband client, generates the following error:

Failed dependencies:
libcrypto.so.4 is needed by sify_bband-3.0-0.i386
libssl.so.4 is needed by sify_bband-3.0-0.i386


To resolve this error, I entered the following commands one after the other:

cd /usr/lib

ln -s libcrypto.so.0.9.8 libcrypto.so.4

ln -s libssl.so.0.9.8 libssl.so.4


Executing the last 2 commands generated a message - part of which said "File exists". I got the above workaround to the error from another forum. When I had a look at the /usr/lib directory, all the 4 files - libcrypto.so.0.9.8, libcrypto.so.4, libssl.so.0.9.8 & libssl.so.4 resided in the /usr/lib directory.

But when I again executed the second RPM package (which had generated the error earlier)

rpm -ivh sify_bband-3.0-0.i386.rpm

the same error got generated again. I guess this error could be the reason why I am not being able to connect to the Net using the broadband client.

I also came across an article which said that to override dependencies, one can use the nodeps flag in the rpm command. So I executed the second RPM package by changing the command to

rpm -i -nodeps sify_bband-3.0-0.i386.rpm

But it generated the No such command found (or something of that sort) error.

Can someone please help me resolve this issue?

Thanks,

Ron