Find the answer to your Linux question:
Results 1 to 9 of 9
I tried to install Ubuntu, ZenWalk, and later Suse on my Dell Inspiron 1100 laptop and after going through the installation processes for zenwalk and suse, it turned out X ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Location
    Cape Cod, MA
    Posts
    5

    Dell Inspiron 1100 trouble


    I tried to install Ubuntu, ZenWalk, and later Suse on my Dell Inspiron 1100 laptop and after going through the installation processes for zenwalk and suse, it turned out X couldnt start because of my monitor or video card. ubuntu gave me a slightly different version of the same problem. is anyone familiar with this problem? I'd really like to get my laptop running

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Which Graphics Card do you have? It looks like Graphics Card problem only. Did you try to install SuSe in Text Mode?
    Try Ubuntu Alternate Installation CD. It has Text Based installer. Its easy to fix/install Graphics Driver after OS installation.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Location
    Cape Cod, MA
    Posts
    5
    Intel Corp. 82845G/GL (shared memory). Yeah, suse and zenwalk installed fine and then wouldnt start the x server. I think its a monitor problem because zenwalk gave me a list of options (there were about ten options and they all looked something like "00 x 00") for the monitor and a "scan" options. suse is installed right now and although Im a newb id be open to some guidance as far as trying to get things running using the command line.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Boot up SuSe, Log in as Regular User and execute this
    Code:
    su 
    sax2 -m 0=vesa
    exit
    startx
    In case it doesn't work
    Code:
    less /etc/X11/xorg.conf
    Post Monitor, Screen and Video Card Sections here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Nov 2006
    Location
    Cape Cod, MA
    Posts
    5
    ok so here is the original error message:

    (EE) I1810(0): Monitor 2 cannot be specified on single pipe devices
    (EE) Screen(s) found, but none have a usable configuration

    Fatal error:
    no screens found

    after changing "sax2 -m 0=vesa" and executing "startx" i got a GUI for the monitor configuration menu albeit a blurry, shaky GUI and it wasnt big enough to show all the information

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Highlight SuSe title in GRUB Menu and press 3. Hit Enter key. SuSe will boot up in command line mode. Log in and execute this
    Code:
    less /etc/X11/xorg.conf
    Post Monitor, Screen and Video Card Sections here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined!
    Join Date
    Nov 2006
    Location
    Cape Cod, MA
    Posts
    5
    Section "Monitor"
    Horizsync 30-38
    Identifier "Monitor[0]"
    ModelName "800X600@60HZ"
    Option "DPMS"
    VenderName "--> LCD"
    VertRefresh 30-61
    UseModes "Modes[0]"
    End Sectioon

    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "800X600"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "800X600"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "800X600"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "800X600"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection

    Section "Device"
    BoardName "i845"
    BusID "0:2:0"
    Driver "i810"
    Identifier "Device[0]"
    Option "NoDDC"
    Option "Clone" "yes"
    Option "CloneRefresh" "50-60"
    Option "SaxDualVSync" "50-60"
    Option "SaxDualHSync" "off"
    Option "MonitorLayout" "DFP,CRT"
    Option "SaxDualHead" ""
    Option "SaxDualMode" "off"
    Option "SaxDualMonitorModel" "1024X768@60HZ"
    Option "SaxDualMonitorVender" "--> VESA"
    Option "SaxDualOrientation" "off"
    Option "SaxDualOrienation" "off"
    Option "SaxDualResoltution" "off"
    VendorName "Intel"
    End Section

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Section "Device"
    BoardName "i845"
    BusID "0:2:0"
    Driver "i810"
    Its using i810 driver. Try "vesa" driver.
    Execute this
    Code:
    su
    nano /etc/X11/xorg.conf
    Replace "i810" with "vesa". Save file ( Press Ctrl+X, Y and hit Enter key ) and reboot machine.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Just Joined!
    Join Date
    Aug 2011
    Location
    Elfers, FL
    Posts
    2
    I tried many distros, always with the same result as the original post. The only thing that worked was appending "acpi=off" to the boot string.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •