Find the answer to your Linux question:
Results 1 to 4 of 4
I'm building a HTPC (probably the main use for this board as it has onboard HDMI and it's µATX) with an Abit AN-M2HD motherboard. The chipset is an nForce 630a. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    8

    Problems installing any linux distro on an Abit AN-M2HD motherboard


    I'm building a HTPC (probably the main use for this board as it has onboard HDMI and it's µATX) with an Abit AN-M2HD motherboard. The chipset is an nForce 630a.

    XP MCE installed fine, as did Vista Home Premium x64. However, ideally I would like to use MythTV.

    My distro of choice for this would be Debian. However, I get a lot of problems when trying to install any linux distro. First off they refuse to detect my SATA DVD drive (a drive which has successfully installed debian, fedora and ubuntu on an Asus Striker Extreme and an Asus P5N32-SLI SE DELUXE without a problem. Using the libata.atapi_enabled=1 flag made no difference, so I temporarily put an IDE dvd drive in there as well to install off that, hoping that the SATA drive could be enabled post install. Debian (note that I have tried Etch, Lenny and Sid on i386 and AMD64) now detected the IDE dvd drive, but failed later on in the installation when trying to detect the motherboard's onboard NIC. I have installed without the NIC but with no networking it becomes quite hard to install anything. The Ubuntu Fesity AMD64 Live CD booted fine (after altering the xorg.conf to use vesa rather than nv. Despite the board using an onboard GeForce 7050 GPU, the xorg nv driver [at least the version that was shipped with feisty] does not work.) and the sata dvd (which, of course, could only have the ubuntu disk in) and networking worked fine. However, the Ubuntu install locked up at 5% (and my caps lock and scroll lock lights started flashing at me). The Ubuntu alternate install behaves just as debian and fedora (and presumably all non-live installs) do.

    I have tried asking this on the Debian forums but have received no help. I'm just hoping someone has tried using this motherboard on this forum, as this forum deals with a wider range of distros.

    The first question is how can I install linux on this board to get it to a working state (with networking and the sata dvd drive)?

    The second question (if I can't get an answer on the first) is how can I get the sata dvd drive and, in particular, networking for this motherboard working post install on debian?

    Thanks

  2. #2
    Just Joined! adwilson99's Avatar
    Join Date
    Jun 2007
    Posts
    37
    Can't help directly, but you mentioned that you had Ubuntu live cd working correctly. Have you tried some of the other live distro's out there? some of them allow you to install off CD, so it might get you up and going enough to run MythTV if that's the main aim.

    These might work for you:


    Or here are some more MythTV specific ones

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    8
    Thanks I'll give some a try. However, I can't just run off a live cd forever as this box is also a replacement for my dvd player and also live cds are incredibly slow (one of the many reasons I would prefer a minimal Debian install).

    I was wondering if being able to boot a live CD off the SATA DVD drive and also having networking meant that I could look up what driver it was using etc. If I could install Debian off an IDE drive then get the networking up later (and also the SATA drive but I don't know how hard that is to get working), it would be a start.

    My 2 questions are still my main aims.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2007
    Posts
    8
    After quite a bit of fiddling with the weirdest 'BIOS' menus ever (my first Abit motherboard and I will stick to manufacturers like Asus now) MythDora 4.0 still didn't detect my SATA drive, but to my surprise it did detect my network card and ask for an IP. I went back and tried my Sid CD but it didn't detect networking as the CD is lost before the driver loads, so I put my IDE drive back in temporarily and it managed to install with networking fine.

    I took the IDE drive back out (need it for my main PC) and installed things like X on the new Debian Lenny i386 box fine. However, I am now without an optical drive as it still doesn't detect my sata dvd drive. With the IDE drive in I only see /dev/hdb and /dev/sda but no /dev/sdb for the SATA DVD drive.

    I'll ask questions about the SATA DVD drive in the hardware forum.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •