Find the answer to your Linux question:
Results 1 to 7 of 7
I am having similar problem to a previuos thread whereby XP won't boot after installation due to partition table problems. however- after having followed instructions on SuSE 9.1 personal site ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3

    SuSE XP Dual Boot Problems


    I am having similar problem to a previuos thread whereby XP won't boot after installation due to partition table problems.

    however- after having followed instructions on SuSE 9.1 personal site for downloading and fixing it still appears to happen

    Can you tell me what data you need (and how and where to get it from) to help me please!

    Can anyone tell me what I can do to fix this - I erally need my XP data and boot back asap!

    Thanks in advance,

    Rob

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    a precise description of what happens and what the other thread was.

    Have you read the tutorial section about boot problems?

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    3

    Details

    I've been running Windows XP but recently decided to set up a dual boot with Linux.

    I got SuSE 9.1 Personal and went through the installatino without any problems.

    When I booted the computer, Linux booted fine and worked like a dream.

    however, when I rebooted and selected windows from the list it gave the following error :

    root (hd 0,0)
    Filesystem type unknown, partition type 0x7
    chainloader +1

    press any key to coninue . . . . . .. .

    When I pressed any key, it went to the Grub boot loader - If I selected windows- the same thing happened.

    I am reliably informed that this is because all linux distros at that time, when trying to partition with windows cause this problem

    Go :
    http://portal.suse.com/sdb/en/2004/0...booting91.html

    However, when I follow the intructions here (I have tried Floppy AND CD) it gets up to the point where it searches for the driverson the media and on one occaision didn't fine them - The next, it did but then when it came up with the options to fix the table - it didn't work - It just came back with the first screen saying would youi like to fix it - it is broken

    Next I rebooted and windows produced the same errors.


    The other thread is :
    http://www.linuxforums.org/forum/viewtopic.php?t=21228

    Thanks,

    Rob

    btw, i posted this once but dont know where it went! - but here it is

    Please help me

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    50
    Just so you all know, its still broken

    I also tried the suse fixes, but they did bugger all. One guy says he solved the problem by downloading this:

    http://www.sysresccd.org/

    and then altering the windows partition. It must rewrite some partition settings or something to make it work, i'm in the process of downloading now, i'll keep you all updated

    Good luck!

  6. #5
    Just Joined!
    Join Date
    Jul 2004
    Location
    Great State of Texas
    Posts
    6
    I went through the same thing withSuSE pro 9.1. I ended up loosing windows bucause SuSE did not support hard RAID according to the response I got. Finally I got Microsuc Virtual PC (see in SuSE forum). Everything is running fine right now. I'll keep yall posted.

  7. #6
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    50
    It worked!!!

    XP and SuSE now both run perfectly!
    Thanks to everybody who helped me with this, especially toddncl, who showed me sysresccd

    I hope this helps other people, if anybody needs any help, give me a shout.

  8. #7
    Just Joined!
    Join Date
    Jul 2004
    Posts
    1

    SuSE & XP

    I had the same trouble as everyone else with the 'Filesystem type unknown, partition type 0x7' error after I downloaded and installed SuSE (needed 'installation with ACPI disabled') to dual boot through Grub with XP. Linux boots, XP doesn't, just gives error.

    I had just purchased this new computer and made the six XP windows recovery CD's and then downloaded the SuSE ISO and a CD burner (later found MagicISO trial burner which seems to work properly and doesn't put adware on my computer). I burned the image and installed SuSE. I remember during the installation it showed the new partitions and squawked a little about Windows cylinder size being > 1024 which might cause problems - I ignored it and pressed on.

    After Linux was installed I tried to boot Windows and got the Filesystem type error previously mentioned. I modified menu.lst to add 'noverify and makeactive' as recommended at one online message board but it didn't help. I also followed the recommendations on the SuSE website which gave a driver update for both CD and floppy and that didn't help (either wouldn't prompt or wouldn't accept either floppy or CD).

    I remembered the max 1024 cylinder message I was warned about during the SuSE installation and decided to start over and maybe change those settings so I recovered Windows XP through the hard drive (first option which pops up on screen when booting) which didn't help, XP still wouldn't boot. I then recovered XP through the six recovery CD's (restarted with first XP recovery CD in CDROM and added other CD's when prompted). That was another time consuming task but then at least XP could boot.

    Here's the strange part - I then put the same SuSE CD I used the first time to install Linux (again, 'installation with ACPI disabled' option) and this time it asked me considerably fewer questions, including skipping the partitioning section. Now Grub gives me the option to boot either Linux or Windows (two of four options) and they both work fine.

    The only thing left is that when I boot with windows, Windows XP says errors were found and asks me if I want to check them and says it will start checking unless I press a key within a few seconds. I always cancel out of that since I'm not sure if that will render XP or Linux useless again. I may post the results if I accidently forget to cancel out of that.

    I'm actually very happy with SuSE and if it weren't for the Konqueror browser not being able to run applets for my mail website, I probably wouldn't ever use XP again. I also downloaded Opera which also failed to run the applet and Mozilla which failed to install.

    Hopefully some of this is useful to someone trying to install Linux.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •