Find the answer to your Linux question:
Results 1 to 2 of 2
Hello: Ok, I tried installing Debian Linux (Sarge) in my windows 2000 laptop. Just some things to keep in mind: 1. I already have windows 2000 installed 2. I DO ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    5

    Problems Dual Booting


    Hello:

    Ok, I tried installing Debian Linux (Sarge) in my windows 2000 laptop. Just some things to keep in mind:
    1. I already have windows 2000 installed
    2. I DO NOT have a floppy drive.
    3. I only have one harddrive
    3. My partition table looks like this:

    hda1 - 17 GBS - NTFS (C:\ windows 2000)
    hda5 - 10 GBS - NTFS (E: this just has a ghost file back up of my C
    hda6 - 500MBS - FAT32( i will use this to move files between linux and windows)
    hda7 - 3.5GBS - ext3 (/home)
    hda8 - 3.5GBS - ext3 (/usr)
    hda9 - 1.0 GB - (SWAP)
    hda3 - 1.5 GB - ext3 (/)


    The hda3, hda7, hda8, hda9 partitions I created during the Linux installation from empty space. The way that I am planning to install Linux is to allow the NTLDR to stay on the MBR and adjust the boot.ini file in windows 2000 so that it adds Linux to the NTLDR boot menu, then to install GRUB to the boot sector of my hda3 partition so in other words let NTLDR worry about initial boot time and GRUB to kick in only once Linux is selected from the NTLDR menu. So when I got to the step in the Linux installation where it asks me where to install GRUB to I said NOT to install to the MBR but to /dev/hda3 and it installed fine and everything. But here is the tricky part, since I dont have a floppy drive I can't just choose to reboot after the installation because then I wont be able to use a boot floppy to boot Linux redering me unable to access Debian.
    So at the end of the installation I choose to switch over to shell. And I was told to do this:
    1. use the dd utility to dump the GRUB boot sector to a file like this:
    # dd if=/dev/hda3 of=/usr/tmp/debian.mbr bs=512 count=1
    2. Then mount my Fat32 partition to copy the file to:
    # mkdir /myCdrive
    # mount -t vfat /dev/hda6 /myShare
    3. The reboot the system and log on to windows
    4. Copy the file from my FAT32 partition to my C:
    5. Add this line to my boot.ini:
    C:\debian.mbr = "Debian GNU/Linux"


    HOWEVER, when I run the "dd" utility from shell it tells me that there is no file called /dev/hda3 so I actually cd into /dev and I cant see no hda3 file nor directory. Is this correct? amd I running the dd utility incorrectly? how come I can't dump the boot sector from hda3 to a file? also is that the correct way to mount a fat32 partition from Debian?

    Any help would be appreciatted.


    P.S.
    I have also lost my ability to boot into windows now. But I am just mainly concerned about getting an answered to the above questions, Thanx!

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    MN USA
    Posts
    70

    RE: Problems Dual Booting

    Although I do not know whats wrong with your dd command. i do have a couple of sugestions that may make things alittle easier for you.

    I run grub in a dual boot system also. I have grub installed onto the linux part (not the MBR) and I have grub booting the system, allowing me to select Linux or Windows and go from there. It's very easy to do, as opposed to setting up the windows bootloader to boot linux - considering you are already in linux!

    Also, you can manually switch between O.S.'s, considering your grub is not on MBR. To change to windows, run fdisk (as root) and change the bootable flag on the linux part AND on the windows part. once done, press p and verify the bootable flag is where it should be and use 'w' to write the file. When you reboot you'll be in windows.

    To get back to Linux, just run windows version of fdisk and change the bootable flag back to linux and reboot.

    Easy, Messy, Temporary solution until you get grub goin'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •