Find the answer to your Linux question:
Results 1 to 6 of 6
I have just switched from Windows XP to Fedora 8 which is running on my Dell Inspiron 6400 laptop. The system is running well but it has come to that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5

    Installing Programs


    I have just switched from Windows XP to Fedora 8 which is running on my Dell Inspiron 6400 laptop. The system is running well but it has come to that time where I am beginning to install programs.

    I have read the sticky post on installing programs and I have followed it through and done the ./configure part. After this is dosen't seam to work anymore. When I type in make it says:

    Code:
    make: *** No targets specified and no makefile found.  Stop.
    I have been trying at this for nearly a day now and would appreciate any help.

    Cheers,

    Chris

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Did ./configure throw any error?

    Which program are you trying to install? Does your machine has internet access? You should install packages through Package Manager, Yum only.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    Looking at the output closely there is a compiler error:

    Code:
    [chris@localhost src]$ cd aqualung-0.9beta8
    [chris@localhost aqualung-0.9beta8]$ ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for type of build... release
    checking for compilation platform... Linux
    checking for gcc... no
    checking for cc... no
    checking for cl.exe... no
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.
    [chris@localhost aqualung-0.9beta8]$

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    checking for gcc... no
    checking for cc... no
    checking for cl.exe... no
    configure: error: no acceptable C compiler found in $PATH
    You have to install C Compiler first.
    Execute this
    Code:
    su -
    yum -y install gcc gcc-c++
    Your machine must have internet access.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    Thanks for that code, It downloaded and installed. However it still won't run the make command.

    Code:
    [chris@localhost aqualung-0.9beta8]$ ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for type of build... release
    checking for compilation platform... Linux
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables... 
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking for ranlib... ranlib
    checking for g++... g++
    checking whether we are using the GNU C++ compiler... yes
    checking whether g++ accepts -g... yes
    checking dependency style of g++... gcc3
    checking how to run the C preprocessor... gcc -E
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking errno.h usability... yes
    checking errno.h presence... yes
    checking for errno.h... yes
    checking fcntl.h usability... yes
    checking fcntl.h presence... yes
    checking for fcntl.h... yes
    checking for stdlib.h... (cached) yes
    checking for string.h... (cached) yes
    checking sys/ioctl.h usability... yes
    checking sys/ioctl.h presence... yes
    checking for sys/ioctl.h... yes
    checking for unistd.h... (cached) yes
    checking dlfcn.h usability... yes
    checking dlfcn.h presence... yes
    checking for dlfcn.h... yes
    checking for an ANSI C-conforming const... yes
    checking for size_t... yes
    checking whether gcc needs -traditional... no
    checking for stdlib.h... (cached) yes
    checking for GNU libc compatible malloc... yes
    checking whether lstat dereferences a symlink specified with a trailing slash... yes
    checking whether stat accepts an empty string... no
    checking for floor... no
    checking for memset... yes
    checking for mkdir... yes
    checking for strdup... yes
    checking for strrchr... yes
    checking for strstr... yes
    checking for strcasestr... yes
    checking for pkg-config... yes
    checking for pthread_create in -lpthread... yes
    checking for dlopen in -ldl... yes
    checking for gzopen in -lz... no
    checking for BZ2_bzopen in -lbz2... no
    checking whether GTK+ version >= 2.6... no
    configure: error: GTK+ not found or too old (version < 2.6)
    [chris@localhost aqualung-0.9beta8]$ make
    make: *** No targets specified and no makefile found.  Stop.
    [chris@localhost aqualung-0.9beta8]$

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    aqualung-0.9beta8 requires GTK+ version >=2.6 and Fedora 7 doesn't have that version. Either try installing earlier version of aqualung or upgrade Fedora.
    I am not using Fedora these days and I dont know if GTK+ version >=2.6 is available for Fedora 7 or not. I hope someone else will chime in soon and suggest you installation procedure.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •