I get this error installing flashplayer (puppy 3.0):

# ./flashplayer-installer
./flashplayer-installer: line 69: iconv: command not found
./flashplayer-installer: line 76: [: `)' expected, found 2

ERROR: Your glibc library is older than 2.3.
Please update your glibc library.
+_________________________________________________

I installed with the package manager : 'glibc_locales-2.3.4'