Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 32
Originally Posted by conradinsf devils_casper, thank you for the suggestion. I will do what you recommended regarding the sequence of connections and install steps. I configured the HDs to boot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined! conradinsf's Avatar
    Join Date
    Dec 2007
    Location
    San Francisco, CA
    Posts
    32

    Quote Originally Posted by conradinsf View Post
    devils_casper, thank you for the suggestion. I will do what you recommended regarding the sequence of connections and install steps.
    I configured the HDs to boot master Linux (SATA0) and slave XP (SATA1). Using sudo fdisk -l, I got the following results. Kubuntu is on sda, XP is on sdb:

    Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
    255 heads, 63 sectors/track, 121601 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 1 5863 47094516 83 Linux
    /dev/sda2 5864 11473 45062325 5 Extended
    /dev/sda3 13386 121601 869245020 7 HPFS/NTFS
    /dev/sda4 11474 13385 15358140 b W95 FAT32
    /dev/sda5 5865 6374 4096575 82 Linux swap / Solaris
    /dev/sda6 6375 11473 40957686 83 Linux

    Partition table entries are not in disk order

    Disk /dev/sdb: 250.0 GB, 250000000000 bytes
    255 heads, 63 sectors/track, 30394 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 5 40131 de Dell Utility
    /dev/sdb2 * 6 30392 244083577+ 7 HPFS/NTFS

  2. #22
    Just Joined! conradinsf's Avatar
    Join Date
    Dec 2007
    Location
    San Francisco, CA
    Posts
    32

    XP won't show in GRUB

    Hi all. So after successfully installing Kubuntu on the primary drive (SATA0), I plugged in my old XP drive as slave (SATA1) to try dual-boot. However, Grub does not give me the option to boot XP. I tried the XP drive alone (SATA0), and it works fine. After reading some of the forums, it looks like XP does not like to be anywhere else except on the primary drive. Is this correct?

    sudo fdisk -l gave me the results posted below. It looks like the XP drive is labelled sdb (and not sda like Kubuntu). Will this cause the problem?

    ************
    sudo fdisk -l

    Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
    255 heads, 63 sectors/track, 121601 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 1 5863 47094516 83 Linux
    /dev/sda2 5864 11473 45062325 5 Extended
    /dev/sda3 13386 121601 869245020 7 HPFS/NTFS
    /dev/sda4 11474 13385 15358140 b W95 FAT32
    /dev/sda5 5865 6374 4096575 82 Linux swap / Solaris
    /dev/sda6 6375 11473 40957686 83 Linux

    Partition table entries are not in disk order

    Disk /dev/sdb: 250.0 GB, 250000000000 bytes
    255 heads, 63 sectors/track, 30394 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 5 40131 de Dell Utility
    /dev/sdb2 * 6 30392 244083577+ 7 HPFS/NTFS

  3. #23
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Boot up Kubuntu, Open Terminal and execute this
    Code:
    kdesu /boot/grub/menu.lst
    Add this code at the end of file
    Code:
    title Windows XP
    rootnoverify (hd1,1)
    map (hd0) (hd1)
    map (hd1) (hd0)
    chainloader +1
    Save file and reboot machine. Select Windows XP title from GRUB Menu.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #24
    Just Joined! conradinsf's Avatar
    Join Date
    Dec 2007
    Location
    San Francisco, CA
    Posts
    32
    Quote Originally Posted by devils_casper View Post
    Boot up Kubuntu, Open Terminal and execute this
    Code:
    kdesu /boot/grub/menu.lst
    Add this code at the end of file
    Code:
    title Windows XP
    rootnoverify (hd1,1)
    map (hd0) (hd1)
    map (hd1) (hd0)
    chainloader +1
    Save file and reboot machine. Select Windows XP title from GRUB Menu.
    Thank you devils_casper. I've been looking for this code everywhere! Unfortunately, I followed another site's suggestion with the similar problem, but I used the following:
    root (hd1,0)

    I also used sudo kate /boot/grub/menu.lst to access grub and make the changes. However, when I restarted to test the setup, it gave me an "Error 17" error and would not proceed. Do you have an idea how to get around this?

    I also left the office, so I will have to try your suggestion when I get back next week.

  6. #25
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    In case above code doesn't work, boot up from any LiveCD and post the contents of menu.lst file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #26
    Just Joined! conradinsf's Avatar
    Join Date
    Dec 2007
    Location
    San Francisco, CA
    Posts
    32

    Works fine!

    Quote Originally Posted by devils_casper View Post
    In case above code doesn't work, boot up from any LiveCD and post the contents of menu.lst file here.
    Thank you all for your assistance . Now I have a fully functional (?) dual boot system, with Kubuntu and XP Pro. It took a few tweakings, but I think I now have a nice system. I tried to slave the old data drive to copy over the files into one of the new NTFS partitions, but I couldn't seem to mount the old drive. Unfortunately, I think I only have two SATA connections, so I couldn't connect all drives to boot up XP and copy from the original SATA drive to the third drive with the new NTFS partition. My work-around is through an external drive. I will pick your brain about mounting an old NTFS drive onto (K)Ubuntu.

    Now that I have a little taste of this without leaving a sour aftertaste, I am tempted to venture into triple booting with Kubuntu, Ubuntu, and XP Pro. Am I asking for it?

    Let me briefly describe how I partitioned and allocated my drive:

    1. Extended Partition:
    ext3 25GB (/root partition for Kubuntu)
    ext3 2GB (linux-swap)
    ext3 25GB (/home partition for Kubuntu)
    ext3 25GB (empty; future place of /root for Ubuntu?)
    ext3 25GB (empty; future place of /home for Ubuntu?)
    unpartitioned 10GB

    2. Primary Partition: 420 GB NTFS (Data drive)

    3. Primary Partition: 420 GB NTFS (Additional data drive)

    Spare 10GB (plus or minus)

    I want to install Ubuntu on the other ext3 partitions, and just share the same linux-swap partition as Kubuntu. I decided to separate the /home partitions for Kubuntu and Ubuntu, but I don't know if this is required. I have enough space, so I separated them. The only reason for the Kubuntu and Ubuntu is to play/learn between the KDE and Gnome systems.

    I am copying some files into my first NTFS partition (which may take a few hours). I won't get back to this until tomorrow.

  8. #27
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You can install as many OSes as you like. Installer will take care of multiple booting.
    Install ntfs-3g package to enable NTFS write access.
    Execute this
    Code:
    sudo apt-get update
    sudo apt-get install ntfs-3g
    Post the contents of /etc/fstab file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #28
    Just Joined! conradinsf's Avatar
    Join Date
    Dec 2007
    Location
    San Francisco, CA
    Posts
    32

    /etc/fstab file content

    Quote Originally Posted by devils_casper View Post
    You can install as many OSes as you like. Installer will take care of multiple booting.
    Install ntfs-3g package to enable NTFS write access.
    Execute this
    Code:
    sudo apt-get update
    sudo apt-get install ntfs-3g
    Post the contents of /etc/fstab file here.
    Thanks again, devils_casper. Here is the content of my /etc/fstab file. It is a direct copy&paste from the terminal program.

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda5
    UUID=e4dd21b1-88b5-4d5c-9987-04898b225a2d / ext3 defaults,errors=remount-ro 0 1
    # /dev/sda6
    UUID=427b04ad-20e8-48d1-992b-62a2b70e48d3 /home ext3 defaults 0 2
    # /dev/sda2
    UUID=139B15E6147CB728 /media/sda2 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
    # /dev/sda3
    UUID=2F757E9A7E506B2A /media/sda3 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
    # /dev/sda8
    UUID=68dd2840-52c6-4ce1-8a31-bce69f6b63e2 /media/sda8 ext3 defaults 0 2
    # /dev/sda9
    UUID=79da9f3d-46bf-4342-bff5-24f85149d74a /media/sda9 ext3 defaults 0 2
    # /dev/sda7
    UUID=d4b7b11a-2b7c-4d2e-842c-47215030ed0c none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/scd1 /media/cdrom1 udf,iso9660 user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

  10. #29
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you installed ntfs-3g package?
    If yes then edit /etc/fstab file
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda5
    UUID=e4dd21b1-88b5-4d5c-9987-04898b225a2d /            ext3    defaults,errors=remount-ro 0       1
    # /dev/sda6
    UUID=427b04ad-20e8-48d1-992b-62a2b70e48d3 /home           ext3    defaults        0       2
    # /dev/sda2
    UUID=139B15E6147CB728 /media/sda2     ntfs-3g    defaults,umask=0 0 0
    # /dev/sda3
    UUID=2F757E9A7E506B2A /media/sda3     ntfs-3g    defaults,umask=0 0 0
    # /dev/sda8
    UUID=68dd2840-52c6-4ce1-8a31-bce69f6b63e2 /media/sda8     ext3    defaults        0       0
    # /dev/sda9
    UUID=79da9f3d-46bf-4342-bff5-24f85149d74a /media/sda9     ext3    defaults        0       0
    # /dev/sda7
    UUID=d4b7b11a-2b7c-4d2e-842c-47215030ed0c none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/scd1       /media/cdrom1   udf,iso9660 user,noauto     0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
    Save file and execute mount -a command Or reboot machine. All users will have read/write access in /media/sda2 and sda3 folders ( NTFS partitions ).
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #30
    Just Joined! conradinsf's Avatar
    Join Date
    Dec 2007
    Location
    San Francisco, CA
    Posts
    32
    Quote Originally Posted by devils_casper View Post
    Have you installed ntfs-3g package?
    If yes then edit /etc/fstab file
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda5
    UUID=e4dd21b1-88b5-4d5c-9987-04898b225a2d /            ext3    defaults,errors=remount-ro 0       1
    # /dev/sda6
    UUID=427b04ad-20e8-48d1-992b-62a2b70e48d3 /home           ext3    defaults        0       2
    # /dev/sda2
    UUID=139B15E6147CB728 /media/sda2     ntfs-3g    defaults,umask=0 0 0
    # /dev/sda3
    UUID=2F757E9A7E506B2A /media/sda3     ntfs-3g    defaults,umask=0 0 0
    # /dev/sda8
    UUID=68dd2840-52c6-4ce1-8a31-bce69f6b63e2 /media/sda8     ext3    defaults        0       0
    # /dev/sda9
    UUID=79da9f3d-46bf-4342-bff5-24f85149d74a /media/sda9     ext3    defaults        0       0
    # /dev/sda7
    UUID=d4b7b11a-2b7c-4d2e-842c-47215030ed0c none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/scd1       /media/cdrom1   udf,iso9660 user,noauto     0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
    Save file and execute mount -a command Or reboot machine. All users will have read/write access in /media/sda2 and sda3 folders ( NTFS partitions ).
    Just did it. Thanks again.

    I also posted a problem with my dual monitor setup on another thread in Linux Newbie entitled "Dual monitor won't work - Video card is Nvidia Quadro FX 540" Do you think you can help me with that issue as well?

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •