Find the answer to your Linux question:
Results 1 to 3 of 3
My architecture is AMD Athlon 64 X2. I have a disk with Ubuntu 7.10 (32bit x86) installed and working. I have a second disk which I am trying to set ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2008
    Posts
    2

    Gentoo 64bit install problem


    My architecture is AMD Athlon 64 X2. I have a disk with Ubuntu 7.10 (32bit x86) installed and working.
    I have a second disk which I am trying to set up to run 64-bit Gentoo. The Gentoo liveCD won't boot (I have tried LOTS of boot options!), so I have been setting up manually.
    I am now at the stage where I want to chroot to the Gentoo system, but I get chroot: cannot run command `/bin/bash': Exec format error - which is due to the 32bit vs 64bit mismatch, I believe.

    Anyone have any suggestions?

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Have you tried any other 64bit live CD?

  3. #3
    Just Joined!
    Join Date
    Feb 2008
    Posts
    2
    I tried an AMD64 version of Ubuntu, but that wouldn't boot, either. I didn't try every possible boot option tho'. I'll try it. Thanks.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •