Find the answer to your Linux question:
Results 1 to 3 of 3
Dear All, I am having an issue booting into a fat32 partition (~150GB) which contains the BartPE iso. The second partition is of course Linux (ext2 - ~10GB) which I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2

    Issue booting a dual partition.


    Dear All,

    I am having an issue booting into a fat32 partition (~150GB) which contains the BartPE iso. The second partition is of course Linux (ext2 - ~10GB) which I have no issue at all with. These two partitions lay on a Lacie External USB 2.0/SATAII 160GB Drive. The same setup worked on the previous version of that drive, but the only difference was that the drive was a regular IDE drive inside.

    The error msg that I receive when I select to boot into BartPE on the fat32 partition is as follows:

    "NTLDR is missing"

    FYI, We used Flashboot to get BartPE iso boot off the fat32 partition. So, would the introduction of SATAII cause an issue with this setup which worked with an IDE, if so what modifications would I need to do to get this going? Thanks.


    -Mike V.

  2. #2
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    My guess is that it has something to do with the order of drives
    on the system. When it tries to boot, instead of looking on itself
    for ntldr, it is looking on another drive. Probably a bug in BartPE

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2
    I narrowed it down a bit. The new usb drive works on newer hardware which has an sata controller onboard, but not on the older laptops such as the Panasonic CF-18s that don't have a sata controller.

    Let me ask another question then, does the usb interface encapsulate the sata protocol when transferring data back and forth or does it dumb it down when going over the usb media?


    -Mike V.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •