Find the answer to your Linux question:
Results 1 to 8 of 8
I just updated ubuntu 7.04 to 7.10. After the update, it asked if I wanted to enable the nvidia driver. I clicked yes. Upon rebooting I got an error and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    98

    No GUI


    I just updated ubuntu 7.04 to 7.10. After the update, it asked if I wanted to enable the nvidia driver. I clicked yes. Upon rebooting I got an error and no gui, just the command line. Does anyone know how I can fix this, or how to disable the nvidia driver from the command line?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Boot up in command line mode and execute this
    Code:
    sudo dpkg-reconfigure xserver-xorg
    Reconfigure display settings and reboot machine.
    Code:
    sudo shutdown -r now
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    98
    Thanks for the reply. I tried a solution that I found on google, but it didn't work. Now I don't even get a command line, just a blank screen. How can I boot to get a command line to implement the code you suggested? Sorry, I'm a newbie.

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Highlight Ubuntu title in GRUB Menu and press 'e'. Select kernel line and press 'e' again. Type single and hit Enter key. Press 'b'. Ubuntu will boot up single user command line mode.

    Highlight Ubuntu title -- e -- select kernel line -- e -- type single -- hit Enter key -- b.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Feb 2007
    Posts
    98
    I tried reconfiguring, but it didn't work. Apparently I don't know how to properly configure it. Is there anyway I can revert back to what it was before I checked "enable nvidia"?

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute sudo dpkg-reconfigure xserver-xorg command again and select "nv" driver instead of "nvidia". In case it doesn't work, select "vesa" driver.

    You can edit /etc/X11/xorg.conf file directly. Just set Driver value to nv or vesa in Section Device 'Video Card" in xorg.conf file.
    Code:
    sudo nano /etc/X11/xorg.conf
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Feb 2007
    Posts
    98
    Thanks!!!
    nv didn't work but vesa did.

  8. #8
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by lwpack View Post
    I just updated ubuntu 7.04 to 7.10. After the update, it asked if I wanted to enable the nvidia driver. I clicked yes. Upon rebooting I got an error and no gui, just the command line. Does anyone know how I can fix this, or how to disable the nvidia driver from the command line?
    Likely what happened was when you upgraded a new version of the Linux kernel was installed. Nvidia's driver has to be compiled against your specific version of the kernel otherwise it won't work. You could either reinstall the driver yourself manually now that you have a GUI working or you could let Ubuntu do it for you with the Restricted Drivers Manager in the System->Administration menu.
    Registered Linux user #270181
    TechieMoe's Tech Rants

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •