Find the answer to your Linux question:
Results 1 to 1 of 1
GNU/Grub is launching GRUB2 and calling existing GRUB Grub-legacy. Mandriva is on the bleeding edge with 2008 Spring. I installed Mandriva (got Grub2) then I used set-up to get back ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! rambutan's Avatar
    Join Date
    Jun 2005
    Location
    Ridgeland, WI, USA
    Posts
    72

    Cannot Boot into GRUB2 (Madriva) Grub Error 2


    GNU/Grub is launching GRUB2 and calling existing GRUB Grub-legacy. Mandriva is on the bleeding edge with 2008 Spring.
    I installed Mandriva (got Grub2) then I used set-up to get back to my usual menu.lst etc only to find Mandriva is locked out behind a Grub Error2. Seems the new grub does not have stage 1.5 grub-legacy refuses to boot the OS without it.
    The obvious answer is to put Mandriva on a Grub-legacy diet.
    Here is what worked on two PCs.
    Boot my old Linux, empty a partition (call it Mandriva.new) and mount it.
    cp -a /Mandriva.old/* /Mandriva.new/
    delete /Mandriva.new/boot/grub
    copy /MyoldOS/boot/grub to /Mandriva.new/boot
    Add the stanza to menu.lst and it boots Mandriva via grub-legacy.
    Here is my puzzle.
    If I just copy /MyoldOS/boot/grub to /Mandira.old/boot it will not boot! I still get Error 2.
    When I run grub-install to /Mandriva.old/boot I get a
    "file /Mandriva.old/boot/grub/stage1 not read correctly"
    and it still will not boot. It only works after a "cp -a" into a new partition!?!
    Anyone know the answer to the puzzle?

    Two more clues.
    1. I see bug reports talking about inode sizes. I don't know what they're talking about. Could it be that "cp -a" drops the new larger inode size down to the older size and all is well?
    2. I saw one person saying they solved it with chainloading like for Windows.
    Last edited by rambutan; 04-15-2008 at 09:27 PM. Reason: more info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •