Find the answer to your Linux question:
Results 1 to 9 of 9
Hi friends Tried Installing GYACHI a Chat protocol which is a replica of Yahoo messenger and has all features like Voice chat, Webcam etc., I downloaded it and tried to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie reiko's Avatar
    Join Date
    Aug 2007
    Location
    Chennai, India
    Posts
    105

    Gyachi Installation Failed!!!!!!


    Hi friends Tried Installing GYACHI a Chat protocol which is a replica of Yahoo messenger and has all features like Voice chat, Webcam etc., I downloaded it and tried to install but it gave me the following error

    Code:
    # ./configure
    Please read INSTALL.txt
    Contents of Install.txt
    Code:
    Steps for building a gyachi executable
    
    1) use the autogen script to generate a configure script:
    
            ./autogen.sh
    
    2) run configure, with any options that you might prefer:
    
            ./configure --disable-rpath --enable-maintainer-mode --prefix /usr --enable-v4l2
    
    3) To generate a Fedora/RedHat spec file
    
            make gyachi.spec
    
       To build an image that will be installed over existing executables
       (not recommended):
    
            make
            make install
    Now when i run ./autogen.sh i'm getting this error!!!!

    Code:
    # ./autogen.sh
    searching for GNU gettext intl directory...
     -> /usr/share/gettext/intl ... no
     -> /usr/local/share/gettext/intl ... no
     -> /opt/share/gettext/intl ... no
     -> /usr/gettext/intl ... no
     -> /usr/local/gettext/intl ... no
     -> /opt/gettext/intl ... no
     -> /usr/gnu/share/gettext/intl ... no
     -> /opt/local/gettext/intl ... no
     -> /opt/local/share/gettext/intl ... no
    ERROR: Cannot find gettext/intl directory.
    ERROR: Install GNU gettext in /usr or /usr/local prefix.
    How to fix this one!!!!!!!!!Pls help me!!!!!!!!

  2. #2
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    Just do what it says: install gettext
    Look in your distro's package manager.

  3. #3
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by darkrose0510 View Post
    Just do what it says: install gettext
    Look in your distro's package manager.
    Yep. You might need to install some gettext-dev or -devel package as well.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie reiko's Avatar
    Join Date
    Aug 2007
    Location
    Chennai, India
    Posts
    105
    gettext and gettext devel package is already installed. Now what should i do next!? How can I fis this???

  6. #5
    Linux Newbie reiko's Avatar
    Join Date
    Aug 2007
    Location
    Chennai, India
    Posts
    105
    Hey ppl I removed and reinstalled the package the previous problem is resolved now I'm getting a new one

    Code:
    # ./autogen.sh
    searching for GNU gettext intl directory...
     -> /usr/share/gettext/intl ... found it
    copying gettext intl files ...
    running aclocal ...
    aclocal:configure.ac:12: warning: macro `AM_DISABLE_STATIC' not found in library
    aclocal:configure.ac:13: warning: macro `AM_PROG_LIBTOOL' not found in library
    aclocal:configure.ac:25: warning: macro `AM_PATH_GTK_2_0' not found in library
    aclocal:configure.ac:26: warning: macro `AM_PATH_GLIB_2_0' not found in library
    running libtoolize ...
    running autoheader ...
    running automake ...
    running autoconf ...
    configure.ac:12: error: possibly undefined macro: AM_DISABLE_STATIC
          If this token and others are legitimate, please use m4_pattern_allow.
          See the Autoconf documentation.
    configure.ac:13: error: possibly undefined macro: AM_PROG_LIBTOOL
    configure.ac:25: error: possibly undefined macro: AM_PATH_GTK_2_0
    configure.ac:26: error: possibly undefined macro: AM_PATH_GLIB_2_0
    autoconf failed, stopping.
    Now how can fix this one!!!!!!!!?????

  7. #6
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Before continuing, check the README or INSTALL file in that package. The dependencies should be listed anywhere. My guess if that you also need the devel packages for gtk+-2 and glib. But there could be some more.

  8. #7
    Linux Newbie reiko's Avatar
    Join Date
    Aug 2007
    Location
    Chennai, India
    Posts
    105
    Hello ppl after googling they provided me a trick
    Code:
    ./configure --enable-shared=bfd,gdb
    I followed it and now I m getting a new error

    Code:
    checking for GTKHTML... configure: error: Package requirements (libgtkhtml-2.0 >= 2.0) were not met:
    
    No package 'libgtkhtml-2.0' found
    
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    
    Alternatively, you may set the environment variables GTKHTML_CFLAGS
    and GTKHTML_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    Now How can I escape from this problem!!!!!!!!!!! I installed gtkhtml2 using my package manager!!!!!!!!!!

  9. #8
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    The error is giving you the solution. Install everything that's missing. To compile stuff you need the source for all the implied libraries. As I already told you: use the README, INSTALL or whatever docs are included to determine all the dependencies and install them.

    If there's no documentation in the tarball go to the web site, forums, mailing lists or whatever. Or just continue the try and error method until you have installed all the related -devel packages.

  10. #9
    Just Joined!
    Join Date
    Sep 2009
    Posts
    1

    solved the problem

    apt-get install the following:
    libgtkhtml2-dev
    libjasper-dev
    imagemagick

    libgtkhtml2-dev is definitely needed and the last two i did just to be sure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •