Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 33
Nor windows nor linux bout up after removing these lines and making the second HD to boot first. I get the same errors as before. I am going to reinstall ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23

    Nor windows nor linux bout up after removing these lines and making the second HD to boot first.
    I get the same errors as before.
    I am going to reinstall linux making the second as primary.
    (we may solve the problem but this is more quickly)

  2. #22
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    title Ubuntu 8.04, kernel 2.6.24-16-generic
    root (hd1,0)
    According to menu.lst file, GRUB has been installed in MBR of Windows HD. Have you tried to set Windows HD as First boot device? Does GRUB Menu appear?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #23
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23
    Yes, i have tried.But the grub menu doesnt appear!!

  4. #24
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Either follow Jonathan's instructions to re-install GRUB in MBR of Windows HD
    Or
    Plug-in Linux HD as Primary, Windows HD as Secondary, re-install Linux. Set Primary Disk as First Boot Device after Linux Installation. GRUB Menu will appear at startup.

    Boot up Ubuntu and edit menu.lst as I suggested in post #4.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #25
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23
    There is re-install option in ubuntu(i dont remeber)?
    or it is full instakllation.I am aking this because i have many files in linux box.

  6. #26
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    There isn't any re-install option and you have to back up data.
    We can fix this problem without re-installation. Could you post the contents of /etc/fstab file?
    I think it will take less time than installation.
    What I am suggesting is, edit menu.lst and /etc/fstab files, re-install GRUB using SuperGRUB CD.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #27
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23
    The content is:

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sdb1
    UUID=81f8a98f-a77f-413b-884f-5426432bf93b / ext3 relatime,errors=remount-ro 0 1
    # /dev/sdb5
    UUID=6448f4ce-181c-465a-8fed-b7c6a9fbbeae none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    /dev/sda1 /media/hda1 ntfs 0 0

  8. #28
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Quote Originally Posted by Jonathan183 View Post
    It sounds as though you have Windows installed to the primary, Linux installed on the secondary hard drive ... but you have changed the BIOS boot order. I suggest you change the BIOS boot order back as it was and reinstall grub to the Windows disk MBR either using the SuperGrub CD or boot from the live CD and use
    Code:
    grub
    root (hd1,0)
    setup (hd0)
    quit
    them reboot the system.
    Quote Originally Posted by devils casper View Post
    Remove mapping code from Windows title block. Windows OS should boot up fine.
    Code:
    title Microsoft Windows XP Professional
    rootnoverify (hd0,0)
    makeactive
    chainloader +1
    I assume that Ubuntu is booting up fine right now and problem is with Windows OS only.
    Based on the information you have provided if you want to retain Windows as the primary hard drive, set BIOS to boot from Windows hard drive first, reinstall grub as indicated above (I've updated based on fdisk output) and modify grub menu.lst as indicated by devils casper. This should give you as system which boots both OS again.

    Just keep in mind that if you remove either hard drive in future you will need to re-install bootloader to the remaining hard drive. If the Windows disk is retained then SuperGrub will fix the boot, if the Linux drive is retained SuperGrub can be used to reinstall grub (but you will need to manually update the menu.lst to have (hd0,0) rather than (hd1,0) entries.

  9. #29
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23
    Now posting from linux!!
    Windows dont boot.Did you told me to add these lines[0] or to remove them from the menu.lst?


    [0]
    map (hd1) (hd0)
    map (hd0) (hd1)

  10. #30
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    The lines should be removed because Windows is on the first hard drive. You should find devils casper's entry for Windows which I repeated in my previous post works.

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •