Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 33
Hi all, i have 2 hard disks, the first one i have install windows and the second linux. i format windows.Then i reboot and i dont see grub menu,ok this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23

    Grub problem


    Hi all,

    i have 2 hard disks, the first one i have install windows and the second linux.
    i format windows.Then i reboot and i dont see grub menu,ok this is normal.
    i had follow a guide and reinstall grub.i also set the second hard disk to boot first(from bios).Then i get the grub menu but i cant boot nor windows nor linux.
    taking this error:
    "filesystem type unknown partition type 0x7"
    "error 17:cannot mount selected partiotion"

    Thanks

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi conanon !

    Which Linux distro are you using?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23
    I am using Xubuntu(8.04).
    i have installed grub from ubuntu(6.10).

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Okk !
    Unplug Linux HD and keep Windows HD plugged in as Primary.
    Does Windows OS boot up?

    Unplug Windows HD and plug-in Linux HD as Primary. Does GRUB Menu appear? Does Xubuntu boot up?

    First of all, make sure that both OSes must boot up independently.

    If both OSes boot up fine, Plug-in Xubuntu HD as Primary and Windows HD as Secondary ( Slave ). Set Primary HD as First Boot Up Device in BIOS. GRUB Menu should appear at start up and Xubuntu should boot up fine. Now open /boot/grub/menu.lst file with root privileges.
    Code:
    sudo nano /boot/grub/menu.lst
    Add this code at the end of file :
    Code:
    title Windows XP
    rootnoverify (hd1,0)
    map (hd1) (hd0)
    map (hd0) (hd1)
    chainloader +1
    Press Ctrl+X, Y and hit Enter key to save file. Reboot machine and select Windows XP title in GRUB Menu.

    In case Windows OS doesn't boot up, post the output of this sudo fdisk -l command here.
    Code:
    sudo fdisk -l
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23
    just a small note is that if i set the windows hard disk to boot first windows boot without grub menu
    also i had already add
    map (hd1) (hd0)
    map (hd0) (hd1)
    to the menu.lst but i hadnt have windows as slave!

    but i am going to see if both boot up unplug.

    thanks for your help!

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Set Primary Disk as First Boot Device and plug in both disks as Primary one by one. Both OSes should boot up fine.
    also i had already add
    map (hd1) (hd0)
    map (hd0) (hd1)
    to the menu.lst
    This code works fine only if you plug-in Linux disk as Primary and Windows Disk as Secondary (Slave).
    It works other way round in a few machines but BIOS/GRUB compatibility problem throws error most of the time.
    Safest and foolproof way is, plug-in Linux disk as Primary.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23
    devils casper,
    something very weird is going on my system.
    Widnows boot fine as primary.
    Making the second HD as primary grub menu appers.
    Trying to boot xubuntu i get "cant mount" "Filesystem type unknown, partition type 0x7".
    Trying to boot windows i get "cant mount" "Filesystem type ext2fs, partiotion type 0x7"
    which is inpossible,windows uses ntfs.

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    It looks like something is wrong with Partition Table of Linux HD or menu.lst file.
    Unplug Windows HD and plug-in Linux disk as Primary only. Boot up from SuperGRUB CD and select Fix Linux Boot Loader (GRUB) option. It will re-install GRUB and Linux will boot up fine. Edit menu.lst file as I suggested earlier.

    In case it doesn't work, I would suggest you to re-install Linux ( We can fix boot up problem but Linux re-install will save a lot of time and hassel ) and edit menu.lst. Make sure to keep Windows Disk un-plugged during Linux Installation.


    * Its 12:32PM here. Going to bed. I will be online again after 8 hrs.
    Have a nice day !
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Quote Originally Posted by conanon View Post
    devils casper,
    something very weird is going on my system.
    Widnows boot fine as primary.
    Making the second HD as primary grub menu appers.
    Trying to boot xubuntu i get "cant mount" "Filesystem type unknown, partition type 0x7".
    Trying to boot windows i get "cant mount" "Filesystem type ext2fs, partiotion type 0x7"
    which is inpossible,windows uses ntfs.
    I suggest with the Linux hard drive only installed as primary you press escape at the grub menu to exit the graphical menu ... then select Linux boot option and press e to edit ... you should have entries something like ...
    Code:
    root (hd0,0)
    kernel ....
    is the first number 0 or 1 ... if it is 1 you installed Linux with Windows disk also connected to the system ... you need to update the hd1 to hd0 in the menu.lst file

    If you have only just installed Linux then follow devils caspers instructions to reinstall Linux with the hard drive set as primary and the Windows hard drive disconnected. If you have been using the installed Linux version a while then boot from the live CD, post the output of fdisk, mount the linux root partition (assume you don't have a separate boot partition) and post the contents of your_root_partition/boot/grub/menu.lst file.

  10. #10
    Just Joined!
    Join Date
    Apr 2008
    Posts
    23
    devils casper good morning!

    Quote Originally Posted by devils casper View Post
    It looks like something is wrong with Partition Table of Linux HD or menu.lst file.
    Unplug Windows HD and plug-in Linux disk as Primary only. Boot up from SuperGRUB CD and select Fix Linux Boot Loader (GRUB) option. It will re-install GRUB and Linux will boot up fine.
    i have reinstall grub succesfully but linux dont boot.
    Trying to boot windows(disk was un-plug) it show me again the cant mount ext2.Also it show me the lines of the menu.lst
    root (hd0,0)
    map (hd1) (hd0)
    ........

    Normal these lines shouldnt be there,i guess grub-installer dont overwrite grub files for some reason.
    Edit menu.lst file as I suggested earlier.

    In case it doesn't work, I would suggest you to re-install Linux ( We can fix boot up problem but Linux re-install will save a lot of time and hassel ) and edit menu.lst. Make sure to keep Windows Disk un-plugged during Linux Installation.

    Extranote:
    my second HD which linux is install has: (as it was primary)
    (hd0,0) ext2fs(why not ext3 by the way?) ubuntu

    (hd0,4) swap

    but i didnt see the 2 and 3 paritions!

    I think that the problem was before windows format and it appears now
    i am going to reinstall it.I am going to keep windows as primary and linux as slave.But what the need of keeping un-plug the windows disk?

    * Its 12:32PM here. Going to bed. I will be online again after 8 hrs.
    Have a nice day !
    Thank you

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •