Sorry Giro I haven't followed your last post since I slept after my last post and today I did something new and it worked!!!

Basically the trick which worked was......
After I installed and even though it said "Installation successfully completed" I didn't reboot and I mounted my hda2 partition then chroot into that and then executed lilo. Now only warnings occured and no Fatal error occured and so after restarting it booted !

I have a few doubts though...
1) At booting that lilo is giving me the following options,
Linux
Linux (some number, i think 2.24.26)
Linux (some number)
hda1(windows)
So what are those 3 Linux? Are they different?

2) After Linux loads I login as user name "gopi" and if I wanted to switch to root user name I typed "Login" and it said "No utmp entry, you must exec "login" from the lowest level "sh".
So how to login to a root user?

3) When I go to /mnt directory and I did "ls -al" it shows hda1,hda2 and some more and as well as floppy->/mnt/auto/floppy
So what does this floppy->/mnt/auto/floppy mean?

Thanks a lot.