hi. i downloaded drivers from the ati site. ive never had a problem with these drivers on redhat. i just installed slackware not too long ago and decided to install the ati drivers to fix the refresh rate. i get this error:


code:--------------------------------------------------------------------------------
# rpm -Uhv fglrx-glc22-4\[1\].2.0-2.5.1.i586.rpm
error: failed dependencies:
/bin/sh is needed by fglrx-glc22-4.2.0-2.5.1
/bin/sh is needed by fglrx-glc22-4.2.0-2.5.1
/bin/sh is needed by fglrx-glc22-4.2.0-2.5.1
/bin/sh is needed by fglrx-glc22-4.2.0-2.5.1
ld-linux.so.2 is needed by fglrx-glc22-4.2.0-2.5.1
libc.so.6 is needed by fglrx-glc22-4.2.0-2.5.1
libdl.so.2 is needed by fglrx-glc22-4.2.0-2.5.1
libm.so.6 is needed by fglrx-glc22-4.2.0-2.5.1
libpthread.so.0 is needed by fglrx-glc22-4.2.0-2.5.1
libX11.so.6 is needed by fglrx-glc22-4.2.0-2.5.1
libXext.so.6 is needed by fglrx-glc22-4.2.0-2.5.1
/bin/bash is needed by fglrx-glc22-4.2.0-2.5.1
libc.so.6(GLIBC_2.0) is needed by fglrx-glc22-4.2.0-2.5.1
libc.so.6(GLIBC_2.1) is needed by fglrx-glc22-4.2.0-2.5.1
libc.so.6(GLIBC_2.1.3) is needed by fglrx-glc22-4.2.0-2.5.1
libdl.so.2(GLIBC_2.0) is needed by fglrx-glc22-4.2.0-2.5.1
libdl.so.2(GLIBC_2.1) is needed by fglrx-glc22-4.2.0-2.5.1
libm.so.6(GLIBC_2.0) is needed by fglrx-glc22-4.2.0-2.5.1
libpthread.so.0(GLIBC_2.0) is needed by fglrx-glc22-4.2.0-2.5.1
--------------------------------------------------------------------------------


my eyes are hurting! please help!