Find the answer to your Linux question:
Results 1 to 4 of 4
I am installing RedHat Linux as 4.0 in my Computer for the first time. Microsoft Windows XP Professional SP 2 is already installed on this PC. I will not made ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    2

    [SOLVED] hdd not detected while installing RHEL as 4


    I am installing RedHat Linux as 4.0 in my Computer for the first time. Microsoft Windows XP Professional SP 2 is already installed on this PC. I will not made it dual boot.

    In the first screen of installation, the installation process detects no hard disk drive attached. It states that "No hard drives have been found. You probably need to manually choose device drives for the installation to succeed. Would you like to select drivers now ?

    And it gives the options for YES and NO.

    When I press YES, it provides a dialog box stating that "The following devices have been found on your system.

    And it gives the options for Done and Add Devices.

    When I press Add Devices, it lists some devices but I don't find the device name for my hard disk : SEAGATE PM-ST3160215AS

    And it states that if the device is not in the list and you have the device driver, Press F2 to add the device driver.

    I don't have any device driver for my SEAGATE PM-ST3160215AS HDD. I don't have any CD accept the motherboard CD that came with the computer.

    Now, my question is how can I find out the device driver for my sata Hard Disk SEAGATE PM-ST3160215AS? Can I find it in the currently running operating system files ? and If I get it, Which files do I need to place in floppy disk so that Linux Installation will detect them from dev\fdd ?

    Please note that HDD is connected and it is detected by the Window XP Operating System.

    Please help me in this regard.
    THANK U

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Hi.

    Is this a SATA hard disk? If it is, then RHEL 4 had poor support for SATA disks, so try a newer version of RHEL 4 or RHEL 5 if you can't find any other solution.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Try passing all-generic-ide option at boot: prompt.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2008
    Posts
    2
    thanks daark.solved problem with RHEL5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •