Find the answer to your Linux question:
Results 1 to 1 of 1
I'm having trouble installing either grub or lilo onto a ProLiant server. I'm hoping someone has seen this problem and maybe has a simple answer. When I try to install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    1

    Need help installing boot loader on ProLiant server


    I'm having trouble installing either grub or lilo onto a ProLiant server. I'm hoping someone has seen this problem and maybe has a simple answer.

    When I try to install grub (my preferred boot loader) using the:
    grub> setup (hd0)
    command, I get an
    error #2: Bad file or directory type
    message. I have verified that the stage1 file is in /boot/grub (or what will become /boot/grub).
    I get the same error if I try installing it onto the boot partition (setup (hd0,0)). I have also tried making my root partition /dev/sda3 (hd0,2) the bootable partition, with similar results.

    When I couldn't get grub to work, I tried lilosetup, but this fails at the end too with a non-specific error message. I also tried lilo with the boot and root partitions, and this also fails.

    I'm pretty certain the problem is that somehow the hardware and/or BIOS is not allowing the boot loader to be written to the drive. I checked through the BIOS settings in search of something to enable/disable writing of the MBR, but didn't find anything. I was able to verify through a diagnostic tool that the BIOS recognizes my first SCSI drive as a bootable drive. The SCSI drive is boot device #3 (#1 is CD, #2 is floppy). I have also set the Adaptec controller as the first bootable controller.

    Specifics of my setup:
    Hardware: HP Proliant DL360 G3, Adaptec 39160, SCSI drive /dev/sda (note that this is an external drive. System has no internal drives installed).
    Software: Slackware 12.1, grub 0.97, lilo (whatever comes with slack12.1).
    Partitioning: /dev/sda: 1-/boot (set bootable in fdisk), 2-swap, 3-/ (all primary partitions).

    I've tried most of this by booting into the Slackware installation CD, and manually mounting the partitions containing grub and lilo.

    Running liloconfig on my Knoppix liveCD maybe illuminates the problem a little? I get the following error:

    Reading boot sector from /dev/sda
    Fatal: Trying to map files from unnamed device 0x000f (NFS/RAID mirror down?)
    Does the BIOS somehow think I have a RAID device configured? The system has an internal RAID controller, but no internal drives. The external drives on the Adaptec are all single drives (no RAID). The Adaptec is a pure SCSI controller. It is not a hardware RAID controller.

    -------------------------------------------------------------------
    New information:

    I tried moving the hard disk configuration and Adaptec card to a system that already has an older Slackware installation. This system has 2 internal IDE drives, and boots GRUB. It is not an HP server, and does not contain an internal RAID controller.

    My first SCSI drive is still /dev/sda, but it shows up to GRUB as hd2 now. I tried "setup (hd2)" and I get the same error.

    Next, I tried placing a nonsense file (foo) at the top level of several partitions, including the known working partitions on the IDE drive and known working partitions on other SCSI drives. Then, from within grub, I attempt "find /foo". It only finds instances on the IDE drives. So, it appears the problem may be that GRUB isn't able to read SCSI? Or for some reason it has trouble with the Adaptec BIOS?
    Last edited by cosflyboy; 07-21-2008 at 03:48 AM. Reason: added information

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •