Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Hey again, I have added a new user from root in text mode. But I cannot log in to that account. The command startx cannot start x-server. Here are the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10

    Hey again, I have added a new user from root in text mode. But I cannot log in to that account.
    The command startx cannot start x-server. Here are the last few lines that comes out of that command:

    Fatal server error
    Addscreen/Screen init failed for driver 0

    giving up
    xinit: Connection refused (errorno 111): unable to connect to X server
    xinit: No such process (errorno 3): server error

    Any tips for this? Does this mean there is a problem with the graphics card that cannot be solved without exchanging the card?

    Would like to have fun.........

  2. #12
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10
    Now I have called Asus support and the tell me they will repair it for me because the graphics card is broken. Thanks anyway for the help Iīve got so far. Doubtless I will come back with more questions later, rest assured.

  3. #13
    Just Joined!
    Join Date
    Oct 2008
    Posts
    1
    Hello,
    I've got the same problem, so I called them, but they told me that they don't support linux at all. Is there a way for me to sole this problem?
    @ Piffilus: Do you have a bill or anything else of the work asus has done on your notebook? Is it possible to get it?
    mfG Boerny

  4. #14
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10
    Well to be honest I havenīt got the graphics in linux to work yet. Asus had the laptop and checked only for problems in windows vista and they couldnīt get the graphics card to crash when they tested it so they did nothing about it and sent it back. I have been in contact with them on telephone and one guy tried to help me but I couldnīt find the usb-stick where the ATI driver file so I could have installed it in textmode is so that is messed too.

    Now I have the driver on a CD but I donīt really know how to point to that location in text mode and copy it to home directory and install. Maybe Iīm too stupid for this since I donīt know the syntax...

    If this doesnīt work Iīll have to get the computer Asus again to change the card anyway because I specificaly bought this laptop to run linux on it and learn it in a little softer way than this way. It couldnīt be so that they sell a computer that canīt run linux just because they say they donīt support that software? Arenīt linux made to be run on every intel pc?

    One strange thing on their download site is that the bios file 202 that is made for (all OS) cannot be flashed to the bios. something seems to be missing in that file. The bios flash program canīt find the file even though it is on the computer in the same folder as the latest bios 203 that is marked XP and Vista and that one the flash program finds. It makes me very tired....

  5. #15
    Just Joined!
    Join Date
    Jul 2008
    Posts
    10
    I've found the solution for this at X.Org Wiki - radeonhd
    where following info can be read:
    "Newer ASUS laptops with more than 2GB of memory. There are several reports about getting RadeonHD (or any graphics driver) to work on Linux on ASUS laptops with M72, M82 and possibly other chipsets when more than 2GB of RAM is installed. This is very likely not a graphics driver issue. For now the only work around is to reduce the amount of RAM installed to 2GB or less."

    So I took out one of the 2GB memory modules and voila I've got linux up and running. Not without problems though. I can't get any sound from HDA Intel or any of the built in soundcards but my Novation X-station USB soundcard works at least most of the time. I can listen to CD:s and mp3:s but when it comes to watching a movie all players I've tested just either play without sound or just quit themselves, my workaround at the moment is to watch them in Windoze, not really what I wanted....

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •