Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, just finished installing Gentoo Linux from the 2008 LiveCD for the second time and I still have the persistent "Error 2" problem with Grub. I have looked at almost ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    4

    Grub Error 2


    Hi, just finished installing Gentoo Linux from the 2008 LiveCD for the second time and I still have the persistent "Error 2" problem with Grub. I have looked at almost every post on the internet about this but still to no avail - any suggestions?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    You are not using correct device name assigned to partitions in grub.conf file.
    Boot up from any LiveCD and execute this
    Code:
    su -
    /sbin/fdisk -l
    Post output here. Post the contents of grub.conf file too.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Posts
    4
    Ok, here's what I got from fdisk about my main HDD:

    Code:
    Disk /dev/sda: 250.0 GB, 25005930016 bytes
    255 heads, 63 sectors/track, 30401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identified: 0x8d44dbc9
    
       Device Boot	    Start	  End	   Blocks	Id	System
    /dev/sda1		1	14376	115474432	af	Unknown
    /dev/sda2	    14376	18293	 31457280	 7	HPFS/NTFS
    /dev/sda3   *	    18294	29766	 92156872+	83	Linux
    /dev/sda4	    29767	30401	  5100637+	82	Linux swap / Solaris
    ..and here's my grub.conf:

    Code:
    default 0
    timeout 30
    splashimage=(hd0,2)/boot/grub/splash.xpm.gz
    title=Gentoo Linux
    root (hd0,2)
    kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3
    initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
    Thanks so much for your help by the way, this has been driving me mad!

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,109
    Error 2 is "Bad File or Directory Type". You have some version of windows on sda2 and Gentoo on sda3. What's on sda1? I think this may be the problem, I'm not really familiar with Gentoo so... Where did you install Grub during the installation? To the mbr or root directory of Gentoo?

  5. #5
    Just Joined!
    Join Date
    Aug 2008
    Posts
    4
    sda1 is my experiment with osx86, so it's HFS+
    The thing is, the Gentoo install gave me no option of installing any form of bootloader & left me with a blank MBR, so I stuck SystemRescueCD onto a blank USB drive & installed Grub from there.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Remove = sign from title line and a few parameters from kernel line.
    Edit grub.conf file.
    Code:
    default 0
    timeout 30
    
    title Gentoo Linux
    root (hd0,2)
    kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 ro root=/dev/sda3
    initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
    In case it doesn't work, post the contents of /etc/fstab file too.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Aug 2008
    Posts
    4
    No difference at all. Here's my fstab:

    Code:
    /dev/sda3	/	ext3	defaults		0 1
    none	   /proc     proc    defaults		0 0
    none	   /dev/shm  tmpfs   defaults		0 0
    it wouldn't have anything to do with the 2008 distros formatting ext3 using 256-bit inodes, instead of 128-bit? Grub 256 bit inode problem

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    it wouldn't have anything to do with the 2008 distros formatting ext3 using 256-bit inodes, instead of 128-bit?
    I don't know and I have to test it myself. It looks like its inode problem only because contents of /etc/fstab and grub.conf files are correct.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •