Find the answer to your Linux question:
Results 1 to 9 of 9
I am running a dual-boot sytem with XP and RH9. The problem I am having is when RH is idle for a while (~30 mins), it stalls my computer and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2003
    Posts
    4

    RedHat 9 power problem


    I am running a dual-boot sytem with XP and RH9. The problem I am having is when RH is idle for a while (~30 mins), it stalls my computer and it won't 'wake up' without me restarting it. I have configured all the screen saver settings and that did not seem to help.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Is this a laptop or a desktop system?

  3. #3
    Just Joined!
    Join Date
    Apr 2003
    Posts
    4
    desktop

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Would you happen to know if the motherboard is ACPI or APM based?

  6. #5
    Just Joined!
    Join Date
    Apr 2003
    Posts
    4
    The motherboard is APM based and I disabled the settings in the BIOS that allow for the motherboard to go into standby. I will see if this works tomorrow. Thanks for the tip.

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It might be a BIOS bug. Would you mind recompiling your kernel to compensate for it?

  8. #7
    Just Joined!
    Join Date
    Apr 2003
    Posts
    4
    I don't mind, but I don't know how. Plus, I have the dual - boot surrepitiously installed on my work computer (I borrowed Admin rights to do it) so I guess I will just have to see if this little fix works. Does recompiling have any chance of damaging other stuff? I will also study up on it to see how to do it. I am, after all, just a newbie.

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Recompiling has very little chance of destroying anything. Just remember to keep your old kernel in case the new one doesn't work. There's a good kernel compiling HOWTO at http://www.tldp.org/. It was updated only a week ago, so I'd say it's pretty likely to be up-to-date. Just install the kernel-source package from your installation CDs.
    While configuring the kernel, the option I want you to enable is "Allow interrupts during APM BIOS calls", under General Setup. You could also try to disable APM support alltogether and see if that helps.

  10. #9
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    If you dont want to go down the recompile route, and you dont really need the power saving feature, then:

    1) Disable Power Management in your systems bios
    2) edit your Grub / Lilo config file to pass "apm=off" to the kernel at boot time.

    That *should* work around the problem.

    Jason

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •