Find the answer to your Linux question:
Results 1 to 9 of 9
I just installed Red Hat 9 (yes, I know it is old) on a spare FAT32 partition on a machine that had been factory pre-loaded with WinXP Home Edition, SP1. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2

    Cannot dual-boot Windows XP after Linux RH9 install


    I just installed Red Hat 9 (yes, I know it is old) on a spare FAT32 partition
    on a machine that had been factory pre-loaded with WinXP Home Edition,
    SP1. The installation went well, Linux boots fine, but I cannot boot WinXP
    any more.


    ********* HERE ARE THE DETAILS ***********

    ======= Prior to Linux install

    I had two physical drives, with two partitions on the first physical drive
    (yes I know C: is the 2nd partition):

    C: IDE Master Drive 0 Partition 1 NTFS ~110GB
    D: IDE Master Drive 0 Partition 0 FAT32 ~5GB
    E: IDE Slave Drive 1 Partition 0 NTFS ~80GB

    ======= After Linux install

    Loaded Linux onto D: (called /dev/hda2 in Linux)

    Used manual partitioning to find the D: drive (hda1) and specified that is
    where I wanted Linux loaded


    From the System Tools => Hardware Browser => Disk Drives screen:

    device start end size type
    /dev/hda
    1 1 <1 Free space
    hda1 1 583 4570 ext3
    hda2 583 14595 109915 ntfs
    14595 14597 13 Free space
    /dev/hdb
    hdb1 1 9964 78160 ntfs


    From the /boot/grub/grub.conf file:

    default=0
    timeout=10
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title Red Hat Linux (2.4.20-
    root (hd0,0)
    kernel /boot/vmlinuz-2.4.20-8 ro root=LABEL=/ hdd=ide-scsi
    initrd /boot/initrd-2.4.20-8.img
    title Windows XP
    rootnoverify (hd0,1)
    makeactive
    chainloader +1


    ======== When I try to boot my PC

    I get the GRUB spash screen with the boot options. When I select Linux,
    the PC boots without a problem. However, when I select Windows XP, I
    see the commands in grub.conf being executed, but then the boot just
    hangs after "chainloader +1".

    Some people, in response to a non-booting XP, have suggested adding:

    map (hd0) (hd1)
    map (hd1) (hd0)

    to the Windows XP section. However, I think that only swaps the drives,
    not the partition on a drive.


    HELP !?!?!?!?!?!?!?

  2. #2
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    Boot up linux, login as root and edit the file: /etc/grub.conf

    Remove or put a # infront of: makeactive

    Save the file and exit.
    Reboot your machine.

    Did this work ?

    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2

    Cannot dual-boot . . . finally reloaded WinXP

    I tried that, did not work. I also tried every possible combination of
    rootnoverify (hd0..hd1, 0..1..2) to no avail. I also tried re-mapping
    (hd0) and (hd1), as well as (hd0,0) and (hd0,1) to no avail.

    I tried every suggested modification, from this and several other Linux
    forums, to the grub.conf file, none of which worked.

    I figured out that, since Linux was on the first HD/first partition
    and Windows XP was on the first HD/second partition (I just used the
    partitioning that HP had provided me pre-loaded,) Linux had replaced
    the WinXP boot loader with GRUB on the first partition but had failed to
    put the WinXP boot loader on the second partition. So, I figured I would
    use the WinXP Recovery System to put the WinXP MBR onto the second
    partition.

    Unfortunately, after I ran bootcfg and fixmbr, the WinXP MBR had been
    put back onto the first partition (Linux) rather than the desired second
    partition, rendering my PC unbootable. At that point, I just gave up
    and decided to re-partition the HD and load WinXP on the first partition
    and create space for Linux on the second partition (backwards from
    before.) I only got as far last night as loading WinXP -- tonight I will load
    Linux. Thanks for the help.

    Incedentally, the partitions were set up the way there were by HP (pre-
    loaded.)

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2004
    Location
    uk, cambs + herts
    Posts
    34
    yeah had similar problem with packard bell there fat32 has other things in the D: drive then just the boot loader which you need to get it up and running. the way youve just done it should work if not remove all the partitions reinstall xp from a standerd cd and then install rh9.

  6. #5
    Just Joined!
    Join Date
    Sep 2004
    Posts
    1
    I had the same problem, try set HDD access mode to Large in BIOS.
    I have discovered that solution by mistake

  7. #6
    Just Joined!
    Join Date
    Sep 2004
    Posts
    1
    Quote Originally Posted by tomis
    I had the same problem, try set HDD access mode to Large in BIOS.
    I have discovered that solution by mistake
    That did not help. Even more - it said "Disk read error"

  8. #7
    Just Joined!
    Join Date
    Sep 2004
    Location
    India
    Posts
    24
    When you run fixmbr from the Windows XP recovery console, you must specify the partition whose mbr you want fixed.
    To do this , first run the Map command from the recovery console to find out the device name for the partition whose mbr you want to fix. It will be something like \Device\HardDisk0
    Then type fixmbr device name
    (where device name would be the name you got from the Map command )
    This should fix the mbr of the desired partition.

  9. #8
    Just Joined!
    Join Date
    Mar 2008
    Posts
    1

    RE: Cannot dual-boot Windows XP after Linux install

    1. boot into linux
    2. vi /boot/grub/grub.conf
    ======================
    #boot=/dev/sda
    default=5
    timeout=5

    #hiddenmenu

    ======================

    hope it can make...

    reg
    saju-

  10. #9
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    shajuthomasn, although we're all happy you're willing to help out, posting an answer to a thread that's 4 years old isn't the best way to do it. There's very little chance that the original poster is still having issues with this. Please do lend a hand to some of our newer posts however.
    Registered Linux user #270181
    TechieMoe's Tech Rants

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •