Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I just bought a Toshiba Qosmio F45 AV411 which go with Vista Ultimate. I updated to 4GB Ram. After shrinking 40GB of hardriver, I tried to install difference versions ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2008
    Posts
    5

    I cannot install linux on my laptop


    Hi,
    I just bought a Toshiba Qosmio F45 AV411 which go with Vista Ultimate. I updated to 4GB Ram. After shrinking 40GB of hardriver, I tried to install difference versions of Linux on my laptop but it still cannot work. I did try with Suse 11, Ubuntu 8.10, Fedora 9 but all of them have problems. With Ubuntu, I cannot boot after installing. It's a problem with Ram. With Suse and Fedora both of them have problem with package fault. I did burn these DVD with the slowest speed and test the DVD before installing. But I get fault at the middle of installing process. The messages are "unhandled exception in anaconda..." for Fedora and "Some Packages Failed" for Suse. There are a list of message so I don't know should I post it here, and because I cannot copy these messages. I did try to select custom and uncheck all of the items of the Fedora which is the latest linux distribution I tried with. This made me think there is maybe some problem with the laptop hardware itself. I would like to know if anyone has this experience before? And is there anyway I can solve this issue?

    Best regards,

  2. #2
    Linux User Daan's Avatar
    Join Date
    Aug 2005
    Location
    The Netherlands
    Posts
    323
    Here there are several people that got Linux to work on their Qosmio laptop:

    Linux on Toshiba Laptops & Notebooks

    Here's a Slackware install on your specific model:

    Getting to Data: Slackware on Toshiba Qosmio F45-AV411

    So it is possible.

    You could try a Debian netinstall if you are think there might be problem with your CD drive. (Try Debian Lenny, not Etch).
    OS's I use: Debian testing, Debian stable, Ubuntu, OpenSuse 12.1, Windows 7, Windows Vista, Windows XP

  3. #3
    Just Joined!
    Join Date
    Nov 2008
    Posts
    5
    Daan,
    From what you say, I did try to reinstall with the iso file of the Fedora on USB hardrive and it works. It means there is something wrong with the Optical Driver. But now I have another issue with the geometry table. I cannot boot after the GRUB is loaded and I got hang at this message:
    "grub loading stage2.."
    Do you have any suggestion?
    I have Vista Ultimate on the first partition and Fedora on the second one.
    Best regards,

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Posts
    3,858
    I am not a expert on grub but I did fix a grub error and got my system to boot using supergrubdisk. Super Grub Disk Webpage
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Just Joined!
    Join Date
    Nov 2008
    Posts
    5
    Hi,
    I don't know the reason why but I finally can boot to Linux.
    One of the weird thing is if I let the system start as default which is boot from HDD, GRUB cannot boot and just give the message "grub loading stage2..". But if I press on the key to display the boot menu and select the HDD, the GRUB can boot the linux. I don't understand what the difference is.
    I fix it by instruction on some website:
    Go to rescue linux
    type GRUB
    GRUB> root (hd0, 2)
    GRUB> setup (hd0)
    restart
    Now I can boot by GRUB from default boot process.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •