I have been going around and around on this problem for months.

I have an ABS G1 Mayhem with a single 80GB Fujitsu drive, as described here.

http://www.buyabs.com/app/Series.asp...o=25&series=76

Yes, I know. I bought it so I could do fast FEM of antennas and digital signal lines, fast evolutionary programming, and faster routing of printed circuit boards - not for gaming. Playing UT2004 though - it screams!

First try:
0. Started computer, found that full 80GB was used for XP.
1. Defragged XP partition.
2. Tried installing Mandrake 10.0 Community Edition. Resized NTFS partition, install went OK. Installed GRUB into MBR of /dev/hda (MISTAKE!)
3. XP no longer booted. If I booted Knoppix, I could still see all of my files, though. Copied important ones to flash drive.
4. Tried to restore MBR using sfdisk, described at:
http://www.redhat.com/archives/fedor.../msg00908.html.
No go.
4.1. Tried making sure that hard drive was in LBA mode. No go.
5. Tried to restore MBR using fdisk /fixmbr. No go.

Second try:
0. Reinstall XP. Use installer to create 1 60GB primary partition and 1 20GB extended partition.
1. Tried to install FC2. Made partitions using the installer:
/hda2 100MB /boot
/hda3 4GB /
/hda4 1GB /swap
/hda5 9.5GB /home
2. Installed GRUB into /boot.
2.1. Using knoppix, use "dd if=/dev/hda1 of=/mnt/sda1/backup.mbr bs=512 count=1" to copy MBR to flash drive.
2.2. Using knoppix, use "dd if=/dev/hda2 of=/mnt/sda1/bootsect.lnx bs=512 count=1" to copy first 512B of /boot to flash drive.
3. Restarted. Planned to copy bootsect.lnx to c:\ and use NTLDR. No XP again?! Black screen.
4. Found that all of kernel 2.6 futzes with the MBR and hoses it for XP, even if you don't create any partitions!

http://www.oreillynet.com/pub/wlg/4896

4.1. Restore MBR using knoppix, flash drive, and dd again.
4.2. XP still doesn't boot.
5. Decide to use Red Hat 8 (kernel 2.4) next time.

THIRD try:
0. Reinstall XP.
1. Dig out Red Hat 8.0 CDs. Check MD5 for integrity.
2. Partition using the control panel/admin tools/storage manager. (I dont' want to touch the MBR with any Linux tools for fear of XP dying.) Create 1 60GB partition and 1 16GB extended partition.
3. Install Red Hat 8.0.
3.1 I use the setup software in RH's anaconda to set up the partitions as before:
/hda2 100MB /boot
/hda3 4GB /
/hda4 1GB /swap
/hda5 9.5GB /home
3.2 Install RH 8.0., putting LILO in /boot, not /dev/hda (did that before, remember?)
4. Boot to knoppix. Using knoppix, use "dd if=/dev/hda2 of=/mnt/sda1/bootsect.lnx bs=512 count=1" to copy first 512B of /boot to flash drive.
5. Boot XP. Look at the partitions.

I have partitioned it as follows (output from the program BOOTPART, the "*" means bootable)

Physical number of disk 0 : 88398839
0 : C:* type=7 (HPFS/NTFS), size= 61440088 KB, Lba Pos=63
1 : C: type=f (Win95 XInt 13 extended), size= 16707600 KB, Lba Pos=122880240
2 : C:* type=83 (Linux native), size= 105808 KB, Lba Pos=122880303
3 : C: type=5 (Extended), size= 5337360 KB, Lba Pos=123091920
4 : C: type=83 (Linux native), size= 5337328 KB, Lba Pos=123091983
5 : C: type=5 (Extended), size= 1050840 KB, Lba Pos=133766640
6 : C: type=82 (Linux swap), size= 1050808 KB, Lba Pos=133766703
7 : C: type=5 (Extended), size= 10213560 KB, Lba Pos=135868320
8 : C: type=83 (Linux native), size= 10213528 KB, Lba Pos=135868383

Looks good.
6. Open boot.ini.
6.1. Add the line below and save:
c:\bootsect.lnx="Red Hat Linux 8.0"
7. Reboot. Select "Red Hat Linux 8.0" from NTLDR boot menu.
8. Nothing. Black screen.
9. Bang head on desk.

...and that's where I am now. My questions:

0. Is there a problem with booting from an extended partition?
1. I see this line in BOOTPART, evidently it thinks the extended partition is Win95?

"1 : C: type=f (Win95 XInt 13 extended), size= 16707600 KB, Lba Pos=122880240"

2. Am I doing the right thing in loading the first 512B of /boot?
3. Are there any linux tools I can use to create partitions that won't kill a NTFS/XP file system?

(holds up a virtual six-pack of Fat Tire)

Help?

Many thanks in advance!

Pete