Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I get an error saying it could not look up internet address for dhcp-1015-44. And it states I can fix it by adding it into the file etc/hosts. How can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2003
    Posts
    11

    dhcp error when login?


    I get an error saying it could not look up internet address for dhcp-1015-44. And it states I can fix it by adding it into the file etc/hosts. How can I do this?

    EDIT: This is the contents of hosts...

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost

  2. #2
    Linux Newbie
    Join Date
    Aug 2001
    Location
    USA, Texas
    Posts
    217
    I have had that problem also ... I just set my hostname manually and had my IP reserved so I always get the same one. ( I work for the company that runs the cable service in my area (not the cable company but an ASP) ).

    but all you really need to do is add the hostname you are given and the ip to your /etc/hosts file. You could set yourself up a script to append to /etc/hosts every time but that would get kinda ugly after a while.

    I would suggest manually setting your hostname and then adding it to the 127.0.0.1 line of the file.

    127.0.0.1 localhost.localdomain localhost myHostName


    see if that works for you.
    [ [ SykkN alloc ] initWithThePowerTo: destroyYouAll ];
    /* Don\'t make me use it! */

  3. #3
    Just Joined!
    Join Date
    Apr 2003
    Posts
    11
    So I put

    127.0.0.1 localhost.localdomain localhost myHostName

    On the hosts file?

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That's not all. You'll first need to to set HOSTNAME=myHostName in /etc/sysconfig/network, and then run "service network restart" (as root).

  5. #5
    Just Joined!
    Join Date
    Apr 2003
    Posts
    11
    Yay! Thx for the help.. Before Apache wasnt even working due to this problem but now it is. Two fixed with one solution .

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You should probably change some things in your apache config as well. Now it is probably using your local hostname for redirections, which is bad for people on the internet (since that name doesn't resolve over the internet). There is an option for Apache to use the hostname that was sent to it for redirections, but I don't remember what that option was called right now. It's probably somewhere around the ServerName directive in your apache config files.

  7. #7
    Just Joined!
    Join Date
    Apr 2003
    Posts
    11
    I got that stuff set, I used to use apache on windows. The only problem I am having problems with now is PHP/MySQL.... I have nooo clue if MySQL is installed cuz I don't see a MySQL in the services, but I do see a grec one...

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    See if you have an RPM based distro, check if you have the mysql-server package installed. In that case, you have it, but you'll also need the php-mysql package installed in order for PHP to be able to use MySQL. It's basically just an interface module between PHP and MySQL.

  9. #9
    Just Joined!
    Join Date
    Apr 2003
    Posts
    11
    Where can I get the php-mysql package? I get this error with phpmyladmin

    cannot load MySQL extension,
    please check PHP Configuration.
    Documentation

    Just installed MySQL, and I have PHP on.. Buuuut I doubt I have the php-mysql package.

  10. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    If this is RedHat, get it on RedHat's FTP or one of its mirrors. You could also look on http://rpmfind.net/.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •