Find the answer to your Linux question:
Results 1 to 2 of 2
SuSE is on a disk all by itself, and when I updated GRUB menu.lst, it returns Code: Error 2: Bad file or directory type Press any key to continue... Can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Apr 2007
    Posts
    298

    [SOLVED] Old GRUB doesn't like SuSE with 256 byte inodes...


    SuSE is on a disk all by itself, and when I updated GRUB menu.lst, it returns
    Code:
    Error 2: Bad file or directory type
    Press any key to continue...
    Can I modify my old v0.97 GRUB to boot SuSE?

  2. #2
    Linux User
    Join Date
    Apr 2007
    Posts
    298
    I chainloaded root partition to boot root with 256 byte inodes.

    Old and new menu entries:
    title openSuSE chainloader <--- WORKED
    root (hd2,1)
    chainloader +1


    title openSUSE in (hd2,1) <--- Didn't work
    root (hd2,1)
    configfile /boot/grub/menu.lst


    title openSUSE 11.1 <---Didn't work
    root (hd2,1)
    kernel /boot/vmlinuz-2.6.27.7-9-default root=/dev/disk/by-id/ata-ST3802110A_5LR74M8V-part2 resume=/dev/disk/by-id/ata-ST3802110A_5LR74M8V-part1 splash=silent showopts vga=0x317
    initrd /boot/initrd-2.6.27.7-9-default

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •