Find the answer to your Linux question:
Results 1 to 3 of 3
Greetings, I recently bought a Toshiba Portege M200 tablet PC and it's caused me no end of grief to load linux on it. I would like to load CentOS 5.x ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    2

    Frustrated With Tablet PC Installation


    Greetings,

    I recently bought a Toshiba Portege M200 tablet PC and it's caused me no end of grief to load linux on it. I would like to load CentOS 5.x (because my hosting company uses it and I will be able to learn as I run it).

    Here are my resources:

    The tablet does not have a CD-ROM drive.

    I found internet resources to create a boot disk that enables me to see my 8GB Sony USB flash drive via DOS. It works nicely.

    I have a laptop drive to USB converter and can access the hard drive directly from my Win XP desktop. I have PowerQuest's Partition Magic Pro (v8.0) and can make Ext2 and Ext3 partitions at will. I have also loaded a program that allows Windows XP to read and write from Ext2 and Ext3. It works well.

    I have tried loading boot images from PXE. This option is mostly out because it seems to be a couple levels past my competency (I haven't been able to get it to work).

    Given those resources, what's the best way to load either the CentOS live CD... or some other approach?

    Any help would be appreciated!

    Thanks!

  2. #2
    Just Joined!
    Join Date
    Apr 2009
    Posts
    2

    Update...

    Since I wrote this, I figured out how to make a boot floppy that can start an external USB CD-ROM/DVD drive. Here are the files on the floppy:

    93,040 COMMAND.COM
    17,175 DISPLAY.SYS
    58,870 EGA.CPI
    58,870 EGA2.CPI
    58,753 EGA3.CPI
    21,607 KEYB.COM
    34,566 KEYBOARD.SYS
    31,942 KEYBRD2.SYS
    31,633 KEYBRD3.SYS
    13,014 KEYBRD4.SYS
    29,239 MODE.COM
    111 AUTOEXEC.BAT
    133 CONFIG.SYS
    25,361 mscdex.exe
    39,729 USBASPI.SYS
    5,509 USBCD.SYS
    22,258 RAMFD.SYS
    16,368 DI1000DD.SYS
    33,191 himem.sys
    32,225 loadlin.exe
    5,832 LINLD.COM

    Here's the contents of my config.sys:

    DOS=HIGH,UMB
    rem device=himem.sys
    lastdrive=Z
    rem device=RAMFD.SYS
    devicehigh=USBASPI.SYS /W /R /v
    devicehigh=USBCD.SYS /d:USBCD

    Here's the contents of my autoexec.com:

    MSCDEX /d:USBCD
    linld image=d:\isolinux\vmlinuz "cl=root=/dev/ram boot=install ramdisk_size=1048576 devfs=mount,dall"

    I can boot to the CD and launch linld.com. The problem is that I keep getting a kernal panic message, saying that a memory block could not be addressed. And when I add the following part to the line above: "initrd=d:\isolinux\initrd.img" the install fails and reboots. I have tried to expand the initrd.img and it appears... blank?

    Could someone help me untwist this problem?

    Thanks!

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,664
    Check out Unetbootin (SourceForge.net: UNetbootin, Universal Netboot Installer). It will allow you to create a liveUSB / install disc with most any Linux distribution, including CentOS 5.x. It runs on Windows and Linux, and creates a bootable USB drive. I use it for just such purposes as you need.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •