Find the answer to your Linux question:
Results 1 to 2 of 2
Title Lilo issues on Mandrake 10.0 with SATA promise raid Architecture X86 MandrakeLinux Version Mandrake Linux 10.0 (Official) Subcategory Installation Question text Some basic information about my system. Dell poweredge ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    5

    Lilo issues on Mandrake 10.0 with SATA promise raid


    Title Lilo issues on Mandrake 10.0 with SATA promise raid
    Architecture X86
    MandrakeLinux Version Mandrake Linux 10.0 (Official)
    Subcategory Installation
    Question text Some basic information about my system.

    Dell poweredge 400sc server
    Promise fasttrak s150 tx2 raid controller
    two disks which I see as sda and sdb.
    installed /boot as raid1 towards the beginning of each drive. Symmetric
    partitions
    installed rest as raid0, symmetric partitions again.


    Installed mandrake, but lilo wont work. Always get L 01 01 01 or L 99 99 99
    errors. \"invalid disk command\" or \"second stage load failed\"

    Read many howto\'s and any other incident google threw my way.

    1) I have tried raid-extra-boot option. No L 99 99 uck
    2) Tried the raid+lilo+howto. Cant use the disk/partition/bios options, since
    lilo v22 is bundled with the install cd\'s (or that is the reason I think)
    3) tried linear and lba32 modes, to prevent disk geometry issues.
    4) put my /boot right in the beginning of the drives
    5) tried copying the mbr to each drives first sector using dd, and also
    copying to my /boot. No luck
    6) tried copying boot sector of /boot partition to windoze, and using it as
    second boot option.

    Other than trying to make a bootable cd or use loadlin, I have pretty much
    exhausted every means for a clean solution to my problems. mebbe grub will do
    better, but I have seen no indication of such a thing, in my google\'ing hunts
    for more information.

    If I could see a kernel panic during boot, I would be a happy man right now.
    Alas it never gets that far.

    Any suggestions about why lilo wont get pass the 1st stage would be very
    helpful. I\'m seriously considering editing the mbr manually. and reading the
    boot sector on my /boot. (not a good idea)

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    please refrain from double posting in the future
    thanks
    -lakerdonald

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •