Find the answer to your Linux question:
Results 1 to 6 of 6
I installed Fedora 10 from a live cd. I think it didnt detect my ethernet card so i m in big trouble. I have decided to manually install the modules ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User vickey_20's Avatar
    Join Date
    Mar 2009
    Location
    Mumbai, India
    Posts
    493

    Some cmds missing in fedora 10


    I installed Fedora 10 from a live cd. I think it didnt detect my ethernet card so i m in big trouble. I have decided to manually install the modules form the driver cd. But cmd for compiling like gcc are not present in the live cd . So how do I go about getting the packages with these command( with no net connection in Fedora)

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    We should start by finding out what your ethernet card is. Post the output of lspci please.

  3. #3
    Linux User vickey_20's Avatar
    Join Date
    Mar 2009
    Location
    Mumbai, India
    Posts
    493

    ethernet is dtected

    thanks for replying . Actually I am on windows right now, the ethernet card is detected n thats no problem as I can see the o/p in lspci but it is not getting the IP automatically from the DHCP that is where the problem is . Something like AVC denial comes when i try to use it ( and what is selinux security, has it got any thing to do with this) . I also tried the same thing use root account , can u tell me how to disable selinux security , coz i think it is causing the problem and not letting dhcp assign IP.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    I think SELinux is creating problems.

    Change SELinux to "Permissive Mode".
    Code:
    su -
    nano /etc/selinux/config
    and change the line
    Code:
    SELINUX=restrictive
    to
    Code:
    SELINUX=permissive
    Press Ctrl+X, Y and hit Enter key to save file.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Linux User vickey_20's Avatar
    Join Date
    Mar 2009
    Location
    Mumbai, India
    Posts
    493

    It worked

    thanks dude u solved my problem , but can u put a little light on how can I start net connection without having to restart my machine. I made the changes as u suggested but had to reboot my machine. Is there a way by which the conf file can be updated without restarting the system. Also how to i update???
    Thanks 1 again!!!

  7. #6
    Just Joined!
    Join Date
    Apr 2009
    Location
    Berkeley, California
    Posts
    20
    Quote Originally Posted by vickey_20 View Post
    thanks dude u solved my problem , but can u put a little light on how can I start net connection without having to restart my machine. I made the changes as u suggested but had to reboot my machine. Is there a way by which the conf file can be updated without restarting the system. Also how to i update???
    Thanks 1 again!!!
    You should probably reboot after making those changes to SELinux, but to start/restart the network without rebooting, simply type (as root)
    /etc/init.d/network restart

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •