Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi, I am quite new to linux, I installed Ubuntu to my external hard drive and that went well but when I tried to add Slackware I could not get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    5

    New Grub error 22


    Hi,
    I am quite new to linux, I installed Ubuntu to my external hard drive and that went well but when I tried to add Slackware I could not get Slack to boot with grub. That was very frustrating so I decided to repartition my drive and install only slack on it (and this time install lilo too) because I really wanted to try it… and that didn’t go that well either =(
    When booting from sdb I got the following message appeared:
    GRUB Loading Stage 1.5

    GRUB Loading, Please wait...
    ERROR 22
    I thought that maybe my Live CDs for slack were corrupted so I installed PCLinuxOS from a magazine as a trial but the same thing happened.
    Windows is still booting fine if my USB HD is disconnected…
    Can anyone help me?
    Thanks! =)

  2. #2
    Just Joined!
    Join Date
    May 2009
    Posts
    14
    There is same post like your error, you can see :

    forum/suse-linux-help/57115-wtf-grub-loading-please-wait-error-22-a.html

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Boot up from LiveCD of any Linux distro and mount / partition of PCLinuxOS. Post the contents of its /boot/grub/menu.lst file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Just Joined!
    Join Date
    May 2009
    Posts
    5
    Hi,
    the contents of /boot/grub/menu.lst file are:

    timeout 25
    color black/cyan yellow/cyan
    gfxmenu (hd0,1)/boot/gfxmenu
    default 0

    title linux
    kernel (hd0,1)/boot/vmlinuz BOOT_IMAGE=linux root=UUID=97c99f45-5ef2-453d-9e55-3092f553d4de acpi=on resume=UUID=b6906ef3-4885-4e31-88ed-17bdc2cf67e5 splash=silent vga=788
    initrd (hd0,1)/boot/initrd.img

    title linux-nonfb
    kernel (hd0,1)/boot/vmlinuz BOOT_IMAGE=linux-nonfb root=UUID=97c99f45-5ef2-453d-9e55-3092f553d4de acpi=on resume=UUID=b6906ef3-4885-4e31-88ed-17bdc2cf67e5
    initrd (hd0,1)/boot/initrd.img

    title failsafe
    kernel (hd0,1)/boot/vmlinuz BOOT_IMAGE=failsafe root=UUID=97c99f45-5ef2-453d-9e55-3092f553d4de failsafe acpi=on
    initrd (hd0,1)/boot/initrd.img

    title windows
    root (hd1,0)
    map (0x81) (0x80)
    map (0x80) (0x81)
    makeactive
    chainloader +1



    thanks for helping!

  5. #5
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Change your windows entry to:

    title Windows
    rootnoverify (hd1,0)
    map (hd0) (hd1)
    map (hd1) (hd0)
    chainloader +1

    This should work when you have your external set to boot first.
    Readin through your first post, I'm not sure if your problem is booting windows with the external attached or if it is booting PCLinuxOS??

  6. #6
    Just Joined!
    Join Date
    May 2009
    Posts
    5
    Hi,

    If the esternal HD is conected I can't boot to anything because I get the Grub error before it get to the first nenu thing. If the external HD is not conected, I have no problems booting to windows.
    Thanks for your help, I will change that in the menu.lst file and comment the result here.

  7. #7
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    If the esternal HD is conected I can't boot to anything because I get the Grub error before it get to the first nenu thing. If the external HD is not conected, I have no problems booting to windows.
    Based on your comment above, my suggestion won't help. It would work if your computer has an option in the BIOS to boot from an external drive, if you have the external drive set to first boot priority in the BIOS and you have Grub properly installed on the external hard drive!

    Genereally the default installation will install Grub to the mbr of the first drive. Since you are able to boot directly into windows without the external drive attached, that did not happen. You must have selected another choice. You will need to install Grub to the mbr of your internal drive. It would seem your Grub stage1 is looking on the wrong partition for stage1.5. Running the command as root: fdisk -l should provide us with your partition information and may be helpful. Also, that is a lower case Letter L in the command, not a one.

    I'm assuming you just have your windows on the first drive and PCLinuxOS on the second??

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    If your machine's BIOS support booting up from External device then I would suggest you to disable Internal disk in BIOS and re-install PCLinuxOS or any other distro of your choice in External disk.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    May 2009
    Posts
    5
    yancek,

    Yes, Windows is in the first drive (sda) and Linux in the second (sdb)

    Running the command as root: fdisk -l should provide us with your partition information and may be helpful. Also, that is a lower case Letter L in the command, not a one.
    the fdisk -l report is:

    [root@localhost root]# fdisk -l

    Disk /dev/sda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xed1f86f7

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 13810 110928793+ 7 HPFS/NTFS
    /dev/sda2 13811 14593 6289447+ 12 Compaq diagnostics

    Disk /dev/sdb: 320.0 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000c3f89

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 243 1951866 82 Linux swap / Solaris
    /dev/sdb2 * 244 19087 151364430 83 Linux
    /dev/sdb4 19088 38913 159252345 7 HPFS/NTFS



    Genereally the default installation will install Grub to the mbr of the first drive. Since you are able to boot directly into windows without the external drive attached, that did not happen. You must have selected another choice. You will need to install Grub to the mbr of your internal drive. It would seem your Grub stage1 is looking on the wrong partition for stage1.5.
    How do I install Grub to the mbr of the internal drive?

    I tried what you suggested before but it did not help (as you predicted)

  10. #10
    Linux User
    Join Date
    Dec 2007
    Location
    Idaho USA
    Posts
    362
    If you install GRUB on your internal hdd then the comp will not boot if the external hdd is not connected.

    You might need to check your BIOS, with my comp to boot from a USB hdd not only must I select USB boot device but in a different screen must enable USB dos support. You do not say just how the external hdd is connected so above may not apply.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •