Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
I'm not sure what else to suggest. Looking back over your posts, I noticed in your second post of the grub.conf file that you have default 0, timeout 0 which ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190

    I'm not sure what else to suggest. Looking back over your posts, I noticed in your second post of the grub.conf file that you have default 0, timeout 0 which means that it will boot the first entry and give you no options. You should not have the timeout set to zero as you don't get any time to select an option on boot. Was that from the SSD grub.conf?

    When you boot from any drive, do you get a menu with several options listed to choose from or does it just boot. Even if there are incorrect entries, you should see several options to choose. Do you?

    Also, to see messages on boot for most distributions, you would press the ESC key on your keboard. Never used Linpus so I don't know if it will work.
    Last edited by yancek; 09-19-2009 at 02:14 PM.

  2. #12
    Just Joined!
    Join Date
    Sep 2009
    Posts
    7
    The default=0, timerout=0 is in the SSD grub.conf. Linpus Lite doesn't have any boot menu (thus no menu.lst). Normally it boots straight to the desktop window in a few seconds (while system is still loading). That unusual behavior may be the root of the problem (see below).

    I have a notebook whose HDD I can remove. I removed the HDD and booted Ubuntu drive as first drive. No problem. I booted Linpus UFD (made using Clonezilla). I got grub> prompt again. I typed "root (hd0,0)...kernel...nosplash...boot". The Caps Lock LED kept blinking and the display showed:

    Uncompressing Linux... OK, booting the kernel.
    TuxOnIce: No attempt was made to resume from any image that might exist.
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

    I used GParted's partition copy/paste feature to clone the Linpus UFD, modified the splash parameter in grub.conf and tried again. No grub> prompt but same error messages above.

    As shown in a previous post, the geometry output is different before the kernel is loaded and after Linpus is successfully loaded. So I think the kernel uses it own code for handling the file system. Volumes have to be mounted to the Linpus file system before they can be used by the kernel. To access the desktop window data, the kernel probably wants to mount the root volume early - even before the USB driver is loaded. For the internal SSD, that is not a problem. For any root system on a USB drive, it will fail, just like any Windows can't boot from USB drives.

    I googled to see if anyone has successfully installed Linpus on a USB drive, but was unable to find one (yet). So Linpus is probably the root of problem.

    Agree?

    Thanks

    wywong

  3. #13
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    The grub.conf file in /boot/grub or /grub directory is basically the same as the menu.lst file and in some distributions they are linked. There should be no reason why you cannot go into the grub.conf on your Linpus SSD as root and edit the timeout and or default settings and add entries. If you are making entries manually at boot, you will obviously have to do that forever if you don't make permanent changes to the grub.conf file. You would obviously need to do the same for the UFD if you are trying to boot from it.

    Not sure what the problem might be but I've never used Linpus and it's not exactly at the top of anyones favorites charts.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •