Find the answer to your Linux question:
Results 1 to 4 of 4
I'm runnng a laptop dualbooted between Windows XP (on NTFS) and Ubuntu 9.x on its own partition. If it matters, it's a Compaq Presario, about 4 years old, with 768 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    3

    Setting permissions on automatically mounted FAT partition


    I'm runnng a laptop dualbooted between Windows XP (on NTFS) and Ubuntu 9.x on its own partition. If it matters, it's a Compaq Presario, about 4 years old, with 768 MB RAM.

    I have a third partition formatted FAT that I would like to have automatically mounted when I boot to Linux, with write permission for all users. In fstab, I have the line
    /dev/sda5 /media/disk-4 vfat auto,users,rw,gid=100 0 0
    (I've tried many other incantations of this line.)

    The problem is that the permissions never let me write to the partition.
    drwxr-xr-x 18 root root 32768 1969-12-31 19:00 disk-4

    I've been asking over at the Straight Dope (http:/ /boards.straightdope.com/sdmb/showthread.php?t=534507 but link broken because I'm not trusted to post a link yet), with lot's of suggestions there, but no solution yet.

    In short, I want a FAT partition automatically mounted, and accessible for read and write by regular users. Either owned by each owner (me or my wife) when they log in, or owned by root, but with read/write permissions for group.

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    Try adding umask=0000 to the line and see if that fixes the problem.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Oct 2009
    Posts
    3
    Quote Originally Posted by Lazydog View Post
    Try adding umask=0000 to the line and see if that fixes the problem.
    Already tried that, and lot's more. See the broken link for the full discussion, but I've tried:

    /dev/sda5 /media/disk2 vfat quiet,defaults,rw 0 0
    /dev/sda5 /media/disk-4 vfat quiet,defaults,rw,exec,umask=0000 0 0
    /dev/sda5 /media/disk-4 vfat auto,users,rw 1 2
    /dev/sda5 /media/disk-4 vfat auto,users,rw,gid=100 1 2
    /dev/sda5 /media/disk-8 vfat quiet,defaults,rw,umask=002,gid=100 0 0
    /dev/sda5 /media/disk-8 vfat quiet,defaults,rw,umask=000,gid=100 0 0

    Nothing ever seems to give me permissions other than
    drwxr-xr-x 18 root root 32768 1969-12-31 19:00 disk-4

    (about the different disk* names, I've been avoiding overwriting previous ones, in case that was part of the problem.)

  4. #4
    Just Joined!
    Join Date
    Oct 2009
    Posts
    3
    I rebooted with
    /dev/sda5 /media/disk2 vfat auto,users,uid=1000,gid=100,dmask=000,fmask=111 0

    in fstab, and can read using both my and my wife's account.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •