Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
I have an AC'97 onboard audio, and While sound files (such as the logon sound on KDE) play, all sound has a terrible static sound mixed in that I think ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2003
    Posts
    29

    Horrible Static sound while playing sound.


    I have an AC'97 onboard audio, and While sound files (such as the logon sound on KDE) play, all sound has a terrible static sound mixed in that I think could be best described as a fly being fried on a bug zapper. Can anyone help me get CLEAR sound?

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    try adjusting your volume levels - might be on xmms (if u use it) and take a really good look at kmix (if you're using kde) and make sure none of the levels are too high

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    First, see if the problem is in the actual sound driver or in the sound multiplexer. You can test the output of OSS (which is the sound driver) by playing an MP3 with this command:
    Code:
    mpg123 -s filename | sox -t .raw -r 44100 -c 2 -sw - -t ossdsp /dev/dsp
    filename is the name of any MP3 file you want to try with.

  4. #4
    Just Joined!
    Join Date
    May 2003
    Posts
    29

    I did the console command...

    But I already knew that this static plays on anything that plays sound. any sound type (mp3, wav etc.) I got it to stop once or twice by messing with the sound configuration in the control center but even that isnt working anymore. and I am not sure exactly what it was that did it in the first place. I was tinkering with turning off aRTs and different set ups in that area. and i am not sure what happened but I had lear sound for a little while but a program crashed and I had to restart so I havent been able to duplicate the clear sound since

  5. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The command wasn't meant to test whether the sound would work an certain types of files, but on certain ways of playing the sound.
    Should I take that reply as an indication that it failed?
    In that case, check if any other programs are using the DSP with "fuser -v /dev/dsp". You'll need to run that as root.

  6. #6
    Just Joined!
    Join Date
    May 2003
    Posts
    29

    Ok I did that...

    USER PID ACCESS COMMAND
    /dev/dsp Philosophy 3808 f.... artsd
    Philosophy 3810 f.... artsd

    That is what it says

  7. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Did you try what yowwww said?

  8. #8
    Just Joined!
    Join Date
    Nov 2002
    Location
    USA
    Posts
    99
    Do you have a PCI sound card, i.e. separate from the motherboard? If so, make sure it is plugged in completely. Sometimes if a sound card has not been properly installed, you will hear static when playing sound files. Just a thought.

  9. #9
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    I had this issue with artsd as well, I don't like those combiner programs. Try turning off artsd, then logging in again, make sure that artsd isn't running (with `ps -auxww | grep artsd`) and see if that stops the problem.
    I respectfully decline the invitation to join your delusion.

  10. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Can KDE applications use OSS if arts isn't enabled? I'm pretty sure that GNOME applications can't do that if esd isn't enabled.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •