Find the answer to your Linux question:
Results 1 to 6 of 6
Ok I have 2 hard drives one with XP(primarry drive) ubuntu 9.10(secondary drive) Everything is fine but the grub at startup. 1)I boot... grub 1.94 beta 4 window pops up ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    38

    grub multi boot problem


    Ok I have 2 hard drives one with XP(primarry drive) ubuntu 9.10(secondary drive)
    Everything is fine but the grub at startup.
    1)I boot... grub 1.94 beta 4 window pops up ok not bad (little too much stuff like mem test) would like xp default "not Ubuntu" whatever.
    2)You selet xp another anoying screen pops up what OS do you want Ubuntu, Windows, or XP setup, (duh just said i wanted xp)the xp setup option is default and it gives you 8 seconds to decide, by the time you find your mouse your into XP setup. (without even a windows setup cd in the drive, weird)
    Dam..how do i cut the crap, I just want it to say windows or xp with xp default.
    tnx
    Peter

  2. #2
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,244
    You need to edit /boot/grub/menu.lst. Find the section headed "default num". This decides which of the menu options is your regular default. If not specified, it defaults to 0 (i.e. the first option on the menu; counting in Linux usually starts at 0). Change it to the number you want.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  3. #3
    Linux Newbie Charles4809's Avatar
    Join Date
    Nov 2008
    Location
    Utrecht, NL
    Posts
    138
    Quote Originally Posted by hazel View Post
    You need to edit /boot/grub/menu.lst. Find the section headed "default num". This decides which of the menu options is your regular default. If not specified, it defaults to 0 (i.e. the first option on the menu; counting in Linux usually starts at 0). Change it to the number you want.
    The above is very true for the "old" Grub. But the OP refers to Grub version 1.94, which is Grub 2. This does not have a menulist at all. Try to Google for GRUB2. At the moment most people are puzzled about how to alter things in Grub2. AFAIK there is a config file somewhere, but even then its very different from what it has been.

    greetings,
    Charles
    (using Grub 0.97 myself)
    Charles
    ASUS EEE Box B202, Atom 270 1,6GHz, 1 GB, HDD 80GB, XP-SP3 / PinguyOS
    Asus EEE PC 901 with Bodhi-Linux

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2009
    Posts
    38

    nice but..

    Ok thanks for the help, but how do I do that?
    I'm new so need more help, what do type in the terminal
    sudo???
    Thanks

  6. #5
    Just Joined!
    Join Date
    Sep 2009
    Posts
    38
    Yay... I'm so smart la la....
    The problem is not with grub but XP each wants to control the mult boot.
    You have to edit your INI file in XP and it ain't that hard, found a site that tells you how to do it Hack the Windows NT/2000/XP Boot Loader found a program in synaptic. Boot manager don't quote me on the name but it lets you customize grub2 not many options but at least you can change your default boot. la la la beer time now.
    Thanks for the help.
    Peter

  7. #6
    Linux Newbie Charles4809's Avatar
    Join Date
    Nov 2008
    Location
    Utrecht, NL
    Posts
    138
    Glad you sorted it out.

    Charles
    Charles
    ASUS EEE Box B202, Atom 270 1,6GHz, 1 GB, HDD 80GB, XP-SP3 / PinguyOS
    Asus EEE PC 901 with Bodhi-Linux

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •