Find the answer to your Linux question:
Results 1 to 5 of 5
Hello. After spending a week-full of evenings on trying to find a generic solution on the internet, I have to resort to posting about my particular situation, as I'm running ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    11

    [SOLVED] Grub Error 17 Cannot Mount Selected Partition


    Hello.

    After spending a week-full of evenings on trying to find a generic solution on the internet, I have to resort to posting about my particular situation, as I'm running out of ideas what else to try.

    I installed Mint 7 KDE community edition on my AMD 64x desktop. The trouble is, I'm trying to save a partition with my /home directory from the previous installation of Debian. Therefore I couldn't just format the whole drive and re-partition it for Mint. Anyway, I deleted all the other partitions and re-installed Mint onto the free space. Straight after the installation I was confronted by Grub Error 17 (which was why I had to abandon Debian in the first place as it kept messing with my partition table after the upgrades). So I followed the advice elsewhere, booted from Live CD and fixed my partition order, which now looks like this:
    Code:
    Disk /dev/sda: 250.0 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x4dcf4dce
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1        1305    10482381    7  HPFS/NTFS
    /dev/sda2            1306        3829    20274030    f  W95 Ext'd (LBA)
    /dev/sda3            3830       30401   213439558+   7  HPFS/NTFS
    /dev/sda5            1306        2524     9791586    b  W95 FAT32
    /dev/sda6            2525        3829    10482381    c  W95 FAT32 (LBA)
    
    Disk /dev/sdb: 40.0 GB, 40027029504 bytes
    255 heads, 63 sectors/track, 4866 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xe90db3fb
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1        1183     9502416   83  Linux
    /dev/sdb2            1184        4866    29583697+   f  W95 Ext'd (LBA)
    /dev/sdb5            1184        1242      473854+  82  Linux swap / Solaris
    /dev/sdb6            1243        4866    29109748+  83  Linux
    Where /dev/sdb6 is my old /home partition. My device map looks like this:
    Code:
    (hd0)   /dev/sda
    (hd1)   /dev/sdb
    So I installed grub using
    root (hd1,0)
    setup (hd1)

    And updated my menu.lst to:
    Code:
    title           Linux Mint 7 Gloria KDE, kernel 2.6.28-11-generic
    root            (hd1,0)
    kernel          /boot/vmlinuz-2.6.28-11-generic root=/dev/sdb1 ro quiet splash
    initrd          /boot/initrd.img-2.6.28-11-generic
    quiet
    
    title           Linux Mint 7 Gloria KDE, kernel 2.6.28-11-generic (recovery mode)
    root            (hd1,0)
    kernel          /boot/vmlinuz-2.6.28-11-generic root=/dev/sdb1 ro single
    initrd          /boot/initrd.img-2.6.28-11-generic
    
    title           Linux Mint 7 Gloria KDE, memtest86+
    root            (hd1,0)
    kernel          /boot/memtest86+.bin
    quiet
    Still, after starting the machine it loads into correct grub and all the entries seem to be correct, i.e. the same as in menu.lst, but the grub reports Error 17 Cannot mount selected device. Further research shows, that this means the disk is found, but cannot be mounted. So I look into my fstab and see that it still tries to mount /dev/sdb2 as my root partition, so I fix it as follows:
    Code:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    # / was on /dev/sdb2 during installation
    /dev/sdb1 / ext3 rw,relatime,errors=remount-ro,data=ordered     1       1
    proc    /proc   proc    defaults        0       0
    # swap was on /dev/sdb6 during installation
    /dev/sdb5       swap    swap    defaults        0       0
    /dev/sdb6       /media/home     ext3    defaults        1       1
    /dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    /dev/scd0       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0
    When I tried to chroot into my Mint directory and mount -a I was told that device for my /home directory did not exist. So I looked in /dev and found out that it had hardly any entries, and none of the sd* ones. My /sys directory was also empty. So I mounted sysfs into my /sys directory and run MAKEDEV -v generic. This populated my /dev directory, although my /sys directory remains empty, when I load from Live CD. This still hasn't solved the problem with grub. And I have no idea what to try next. I feel like I've been messing with things I shouldn't have and I would happily reinstall Mint, but I suspect I will just have to go through everything again. I have a feeling that I'm missing something silly and obvious. Any help would be much appreciated.

    Thanks!

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    I would suggest you to switch Harddisks through Cable select or jumper settings. Linux installer will install GRUB in Linux disk instead of other Harddisk.

    Un-plug/disable first Harddisk, set second as Primary, install Linux and let installer install GRUB in its default location ( MBR of Primary Harddisk ).
    Plug-in first harddisk as Secondary, add entries of first Harddisk's OSes in menu.lst of Linux.

    You won't face any Partition/GRUB related problem in future. Both Harddisks and all OSes in both disks will independent of each other.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    11
    Thanks for the prompt response. I don't think this is the case though. Hard disks and OSes are currently independent. /dev/sda drive has got a Windows XP MBR and /dev/sdb has got Grub installed. And I can choose whichever I want to boot (XP or Grub) by selecting the appropriate drive in BIOS boot menu. The problem seems to be downstream as Grub is loading but unable to mount the drive with root directory. I apologise if I misunderstood your post. Thanks again.

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    It could be GRUB/BIOS compatibility problem. You are setting Second harddisk as First boot device in BIOS which, in a few machines, changes device names assigned to its partitions.

    Don't you think switching Harddisks only once is much easier than changing device order in BIOS on every boot?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Dec 2007
    Posts
    11
    Thanks again. It did work! Well, sort of. I think it would work if I did it the suggested way. The thing is, my drive with GRUB installed should be registered as /dev/sda as it is installed and recognised in BIOS as Channel 0 Master and the second drive with Windows MBR is Channel 1 Master. For some reason, kernel sees them opposite way, while GRUB doesn't! Which creates a paradoxical situation. In order for it to load properly I need to install GRUB onto hd1, but I need to specify root as hd0,0 but still use /dev/sdb1 as the drive with linux root directory. Which doesn't make any sense logically, but works! Thanks so much for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •