Find the answer to your Linux question:
Results 1 to 8 of 8
I was hoping someone can tell me how to change the read write permissions in Fedora 12. I'm trying to obtain /boot/grub/grub.conf, but I'm getting a permission denied message....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    3

    -Permission denied message. (/boot/grub/grub.conf)


    I was hoping someone can tell me how to change the read write permissions in Fedora 12. I'm trying to obtain /boot/grub/grub.conf, but I'm getting a permission denied message.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums!

    You should be able to go to a terminal and use the su command to gain root privileges:

    Code:
    su
    ...or

    Code:
    su -
    ...enter your root password when requested and press ENTER. Once done, you should be able to access files that require root privileges.
    oz

  3. #3
    Just Joined!
    Join Date
    Dec 2009
    Posts
    3
    Ozar,
    Thanks for the help. I was already login as the root. Please look below and offer any other suggestions. THX!


    [jsyn@localhost ~]$ su
    Password:
    [root@localhost jsyn]# /boot/grub/grub.conf
    bash: /boot/grub/grub.conf: Permission denied
    [root@localhost jsyn]#

  4. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Try it with the su - option. Note that there is a space between the su and the dash.
    oz

  5. #5
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Quote Originally Posted by jbapt View Post
    [jsyn@localhost ~]$ su
    Password:
    [root@localhost jsyn]# /boot/grub/grub.conf
    bash: /boot/grub/grub.conf: Permission denied
    [root@localhost jsyn]#
    It looks like you are trying to run grub.conf as a bash script (which it is not), what are you trying to do? if you want to view the contents use cat (you don't need to do that as root)
    Code:
    cat /boot/grub/grub.conf
    If you need to edit the file use nano (you will need root rights for this)
    Code:
    nano /boot/grub/grub.conf
    You can check if the file exists and its permissions using
    Code:
    ls /boot/grub -l
    the -l has a small L rather than a one

  6. #6
    Just Joined!
    Join Date
    Dec 2009
    Posts
    3

    Ubuntu 9.10/Fedora12/XP -Tri boot issues

    Jonathan183-

    Here's my original problem. I've created 3 partitions. The original partition had Unbutu 9.10. I installed Windows XP next. I installed Fedora 12 last, which is on my second partition. Fedora and XP boots up fine. Fedora boots up by default and when I select other as an option, XP boots up automatically. However, when I select the Unbuntu boot, I receive an, " Error 15: file not found message". I ran the cat /boot/grub/grub.conf. Hopefully, I've provided enough info to get some help. I need to edit the my grub file it appears. Please advise.


    jsyn@localhost ~]$ cat /boot/grub/grub.conf
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You do not have a /boot partition. This means that
    # all kernel and initrd paths are relative to /, eg.
    # root (hd0,1)
    # kernel /boot/vmlinuz-version ro root=/dev/sda2
    # initrd /boot/initrd-[generic-]version.img
    #boot=/dev/sda
    default=0
    timeout=5
    splashimage=(hd0,1)/boot/grub/splash.xpm.gz
    hiddenmenu
    title Fedora (2.6.31.6-166.fc12.i686)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.31.6-166.fc12.i686 ro root=UUID=807542bb-8a12-491f-bec5-709d968a13f0 noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
    initrd /boot/initramfs-2.6.31.6-166.fc12.i686.img
    title Other
    rootnoverify (hd0,2)
    chainloader +1
    title Ubuntu (2.6.31-14-generic)
    root (hd0,0)
    kernel /vmlinuz-2.6.31-14-generic ro root=/dev/sda1 rhgb quiet
    initrd /initrd.img-2.6.31-14-generic
    [jsyn@localhost ~]$

  7. #7
    Linux Guru Lakshmipathi's Avatar
    Join Date
    Sep 2006
    Location
    3rd rock from sun - Often seen near moon
    Posts
    1,758
    Login as root and post the output of command,
    fdisk -l
    from your grub file
    title Ubuntu (2.6.31-14-generic)
    root (hd0,0)
    kernel /vmlinuz-2.6.31-14-generic ro root=/dev/sda1 rhgb quiet
    initrd /initrd.img-2.6.31-14-generic
    try and mount /dev/sda1 and see whether ubuntu partition files still there or you have installed windows in /dev/sda1

    as root,use mount command,

    mount /dev/sda1 /mnt
    ls /mnt
    did you see ubuntu files?
    First they ignore you,Then they laugh at you,Then they fight with you,Then you win. - M.K.Gandhi
    -----
    FOSS India Award winning ext3fs Undelete tool www.giis.co.in. Online Linux Terminal http://www.webminal.org

  8. #8
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Quote Originally Posted by jbapt View Post
    Jonathan183-

    Here's my original problem. I've created 3 partitions. The original partition had Unbutu 9.10. I installed Windows XP next. I installed Fedora 12 last, which is on my second partition. Fedora and XP boots up fine. Fedora boots up by default and when I select other as an option, XP boots up automatically. However, when I select the Unbuntu boot, I receive an, " Error 15: file not found message". I ran the cat /boot/grub/grub.conf. Hopefully, I've provided enough info to get some help. I need to edit the my grub file it appears. Please advise.

    Code:
    title Fedora (2.6.31.6-166.fc12.i686)
        root (hd0,1)
    
    title Other
        rootnoverify (hd0,2)
        chainloader +1
    
    title Ubuntu (2.6.31-14-generic)
           root (hd0,0)
    Extract from grub.conf indicate you put Fedora on sda2 (hd0,1), Windows on sda3 (hd0,2), and Ubuntu on sda1 (hd0,0).
    First lets confirm the partition structure, post the output of
    Code:
    su
    fdisk -l
    the -l has a small L not a one ...

    also post the output of
    Code:
    mount

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •