Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I am trying to make my system automatically boot beyond the GRUB menu. The system will function as a server, but i have not manage to get it automatically ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Yes!'s Avatar
    Join Date
    Jan 2010
    Posts
    3

    Question [SOLVED] Howto get rid of GRUB bootmenu?


    Hi,

    I am trying to make my system automatically boot beyond the GRUB menu.
    The system will function as a server, but i have not manage to get it automatically boot Linux.

    I have configured the default=0 and timeout=5, but still no luck.

    I have also tried different distro's (Debian Lenny, Centos 5.4), always the same problem. (So probably a hardware configuration problem?)

    The system is a AMD XP 6000+ with 1GB memory.
    The system contains 1 SATA disk (500 GB) and 1 SATA DVD writer.

    The system boots & runs without problems after hitting the enter key in the GRUB menu, but since it is meant to automatically restart after reboot this is not the desired behaviour.

    I have read about some problems with GRUB:
    [utl]https://bugzilla.redhat.com/show_bug.cgi?id=468526[/url]


    Anyone knows how to skip the GRUB bootmenu or point me in the right direction of configuring another boot loader.

    Only thing i need is autostart into my distro.

    Thanks & Regards

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello and Welcome!

    Have you tried timeout=0?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Linux User
    Join Date
    Dec 2007
    Location
    Idaho USA
    Posts
    362
    It should boot with out pressing any key, so must ask did you remove any # sign in frount of the default and timeout entries ?

    If it still does not work post menu., we might see some error.

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    # timeout will disable timeout and GRUB will not any OS unless User selects it manually.

    Set timeout value to 0 and GRUB will load it instantly. In case it doesn't work, post the contents of grub.conf file here. There could be a typo in that file which is not letting timeout to take effect.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined! Yes!'s Avatar
    Join Date
    Jan 2010
    Posts
    3
    Hi,
    thank you all for your suggestions.
    Unfortunately i could not response earlier because i was at the office and this is my personal server at home.


    Quote Originally Posted by jayd512 View Post
    Hello and Welcome!

    Have you tried timeout=0?
    Thanks!
    Yes i did. I also tried totally commenting out the timeout setting, all with no luck.



    Quote Originally Posted by Lostfarmer View Post
    It should boot with out pressing any key, so must ask did you remove any # sign in frount of the default and timeout entries ?

    If it still does not work post menu., we might see some error.
    There were no comment # signs before the entries.
    See my menu here after.


    Quote Originally Posted by devils casper View Post
    # timeout will disable timeout and GRUB will not any OS unless User selects it manually.

    Set timeout value to 0 and GRUB will load it instantly. In case it doesn't work, post the contents of grub.conf file here. There could be a typo in that file which is not letting timeout to take effect.
    I have tried timeout with different value, with no effect at all.


    Here is my current menu:
    Code:
    default=0
    timeout=0
    splashimage=(hd0,0)/grub/splash.xpm.gz
    hiddenmenu
    title CentOS (2.6.18-164.10.1.el5)
            root (hd0,0)
            kernel /vmlinuz-2.6.18-164.10.1.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
            initrd /initrd-2.6.18-164.10.1.el5.img
    title CentOS (2.6.18-164.el5)
            root (hd0,0)
            kernel /vmlinuz-2.6.18-164.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
            initrd /initrd-2.6.18-164.el5.img

    Regards.

  6. #6
    Just Joined! Yes!'s Avatar
    Join Date
    Jan 2010
    Posts
    3
    I have installed Ubuntu Server.
    No problems with booting automatically into the system.

    No idea what caused the problem with Debian & Centos, but for now i'm sticking with this distro.

    Thanks for willing to help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •