Find the answer to your Linux question:
Results 1 to 6 of 6
I want to install deb library on redhat to install .deb packages on redhat. (i doNOT want to convert deb to rpm). I got dpkg i.e. debian package manager at ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    7

    [SOLVED] Problem in installing deb package manager in redhat el5


    I want to install deb library on redhat to install .deb packages on redhat. (i doNOT want to convert deb to rpm).
    I got dpkg i.e. debian package manager at this site->

    sfr-fresh_com/linux/misc/dpkg_1.14.28.tar.gz

    but i am having some error at end of make and thats why its not working
    ( after trying dpkg in terminal like ubuntu its still saying command not found)
    i tried to get rpm of deb from site->

    f tp://ft p.pbone_net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home%3A/puzel%3A/Factory/openSUSE_Factory/src/deb-1.14.21-17.11.src.rpm

    but it have very much dependancy problem. Can anyone help please?

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    That sounds like a terrible idea and a good way to break your system. Why do you want to do that?

    You're also trying to use an opensuse rpm package, which is another good way to try and mess up your system.

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    If you haven't already considered it, YUM would probably be a better package tool for you unless there is some reason that you can't use it.
    oz

  4. #4
    Just Joined!
    Join Date
    Dec 2009
    Posts
    7
    I want to install deb packages in (guest)ubuntu from redhat(host) anyways i got the solution.. thanx man...

  5. #5
    Just Joined!
    Join Date
    Dec 2009
    Posts
    7
    thanx but i have tried it.

  6. #6
    Just Joined!
    Join Date
    Dec 2009
    Posts
    7
    we can use centos repo from link
    ht tp://rpms.plnet.rs/centos5-i386/RPMS.plnet/

    and can get dpkg*.rpm also dependancies there.
    One more point i want to mension that only conversion from .deb to .rpm by alien package was not much useful in my case.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •