Find the answer to your Linux question:
Results 1 to 2 of 2
I have an odd problem. I custom-built a workstation: MSI Speedster 1 mobo 2x Opteron 2352 4x DDR2 ECC 4GB 3x 150GB WD Raptor, hardware RAID 0 1x 2TB WD ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Location
    Augustana College
    Posts
    69

    Grub error 17 after fresh install


    I have an odd problem. I custom-built a workstation:
    MSI Speedster 1 mobo
    2x Opteron 2352
    4x DDR2 ECC 4GB
    3x 150GB WD Raptor, hardware RAID 0
    1x 2TB WD Green, standalone

    I had Linux Mint 8 installed, but before putting the machine to real use decided to toss Windows 7 on there to see how it worked. Now I am attempting to put Mint 8 back on to get everything set up. There have been no hardware changes since I had Mint installed before.

    I can successfully install, but when I reboot I get a Grub error 17. The partition table looks like:
    50GB / ext4
    400GB /home ext4
    ...
    2TB /backup /ext3

    Grub is installed to (hd0), which is the 450GB hardware RAID. It does not make a difference when I run the installation (and then reboot) with the 2TB drive disconnected. Thinking maybe the new ext4 format was messing with Grub, I tried:
    200MB /boot ext2
    50GB / ext4
    400GB /home ext4
    And installed again and rebooted. No dice.

    Any idea what's going on? I'd guess Grub has issues recognizing the hardware raid, except it worked before

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Grub Error 17: Cannot mount selected partition
    This error is returned if the partition requested exists, but the filesystem type cannot be recognized by GRUB.
    Do you get a Grub menu? Do you get this error when selecting windows? Do you get this error when selecting Mint? Both? Did you install windows 7? The general partition information you gave didn't list any ntfs partitions.

    Could you use the Mint Cd and open a terminal to run: sudo fdisk -l command to post your actual partition information?

    Did you install Grub to the master boot record of the 450GB?
    Mint 8 uses Grub2, correct?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •