Find the answer to your Linux question:
Results 1 to 5 of 5
Hi iv been playing around with an old laptop and a hand full of Linux distros. I found that each Linux has a kernel "vmlinuz" and a initrd "initrd.gz" no ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2009
    Posts
    5

    Booting Linux.


    Hi iv been playing around with an old laptop and a hand full of Linux distros.

    I found that each Linux has a kernel "vmlinuz" and a initrd "initrd.gz" no matter how you boot the distro it uses these to files.

    I have CrunchBang Installed on my laptop i put a copy of the ubuntu live disk in the location

    /home/user-pc/ubuntu/

    I added a new boot option for grub It looks like this

    Title Ubuntu
    kernel /home/user-pc/ubuntu/casper/vmlinuz
    initrd /home/user-pc/ubuntu/casper/initrd.gz

    This boots like a normal cd only problem is while its booting it tells me it cant find the file System.

    This happened for every single Linux distro I tried to boot.

    Is there somthing im missing here is there a way to tell the boot peramiter where the file system is i think what it means by file system is the "filesystem.squashfs" file.

    I have 2 questions

    1. Is there anyway to tell the grub loader that this is the file system. To make the live CD boot properly.

    2. how do CD's work is it not the same?

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    https://help.ubuntu.com/community/In...tion/FromLinux

    Obviously, you will not want to run the actual install, but how to boot it is there.

  3. #3
    Just Joined!
    Join Date
    Jun 2009
    Posts
    5
    Thank you i will try this and report back how it went.

  4. #4
    Just Joined!
    Join Date
    Jun 2009
    Posts
    5
    I did what the link said to do but i keep getting partition could not be mounted. I have no idea what its talking about. I got it to tell me anvalid or unsupported executable format.

    When i look in gparted. it shows /dev/sda1 ext3 (puppy linux)
    /dev/sda3 ext3 (the one i made to install linux)
    /dev/sda2 exteded(no idea)
    /dev/sda5 linux-swap

    what would I tell grub to boot from
    i tried 0 1 2 3 4 5 6 7 8 9 and none of them worked. Did I do something wrong?

  5. #5
    Just Joined!
    Join Date
    Jun 2009
    Posts
    5
    Never mind Puppy linux installed a really weird and or old grub that couldent read the kernel i poped my slitaz usb boot floppy in with grub and 10 different boot loaders on it. and i typed in the boot paramaters works fine.

    Thank you so much for the help is there a rep on this forum

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •