Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hi there I know there are a lot of similar topics - still I think I didn't find the answer yet - or maybe I'm just too stupid (what's possible ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    7

    [SOLVED] Another one who can't boot Windows (GRUB)


    Hi there

    I know there are a lot of similar topics - still I think I didn't find the answer yet - or maybe I'm just too stupid (what's possible :P).

    Well let's start:
    On my Laptop is an 80 GB HD. I installed Windows XP first (at this point it worked perfectly) then installed on the same HD, but on other partitions Archlinux.

    The whole thing looks like this now:

    /dev/sda1 <--- Windows xp
    /dev/sda2 <--- arch linux (/, etc, etc^^)
    /dev/sda3 <--- homes
    /dev/sda4 <--- boot partition (grub)
    (I got no SWAP partition, I got 4gb RAM (well can only use 3, since my system doesn't support 64bit), and my friend told me there's no absolute need for a a swap :>)

    Arch Linux is booting perfectly (and very fast), but Windows XP doesn't want to boot anymore :>
    (Just if it's from any importance: In the partition program I took the "bootable" flag away from my XP Partition and set it to sda4 - I thought I need to do that, but now I'm not so sure anymore :P )

    My entry in the file /boot/grub/menu.lst looks like this (I also tried various others)

    title Windows
    root (hd0,1)
    makeactive
    chainloader +1
    When I boot and choose the Windows XP in the GRUB boot menu, the following message appears:

    root (hd0,1)
    filesystem type is ext2fs, partition type 0x83
    makeactive
    chainloader +1

    error 13: invalid or unsupported executable format
    When I set root(hd0,1) to root(hd0,0) (what seemed the most logical to me) and boot again selecting the windows xp, then the GRUB cosole appears.

    So what did I do wrong - or better said: what should I do now?

    Thanks in advance

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    based on your partition structure that you posted it should be root (hd0,0) since grub starts at 0 for everything

    XP partition should be set with bootable flag, linux partition doesn't need this

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    7
    Hey

    Well I already tried this.
    Now I set boot flag back to the windows partition (wiht cfdisk), set the entry to hd0,0 but nothing changed. When I choose XP now the grub console directyl appears.

  4. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    when you boot into arch can you mount windows xp drive and ensure that files are intact?

  5. #5
    Just Joined!
    Join Date
    Feb 2010
    Posts
    7
    Erm i thought it was.

    BUt now I can't mount it

    When i try with ntfs-3g (ntfs-3g /dev/sda1 /mnt/xp):

    Unexpected clusters per mft record (-1).
    Failed to mount '/dev/sda1': Invalid argument
    The device '/dev/sda1' doesn't seem to have a valid NTFS.
    Maybe the wrong device is used? Or the whole disk instead of a partition
    But when I look at the partiions (fidsk -l) /dev/sda1 is shown as HPFS/NTFS .

  6. #6
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Can you post fdisk -l output, also try mounting the partition without filesystem type ... mount /dev/sda1 /mnt/xp ... is the partition mounted? if so what does cat /etc/mtab report?

  7. #7
    Just Joined!
    Join Date
    Feb 2010
    Posts
    7
    fdisk -l (only the xp partition)
    Device Boot Start End Blocks Id System
    /device/sda1 * 1 6243 47197048+ 7 HPFS/NTFS
    without filesystemtype (mount /dev/sda1 /mnt/x):
    mount: you must specify the filesystem type

    edit:

    if needed i can also give one of you guys ssh access..

  8. #8
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Quote Originally Posted by Nasicus View Post
    if needed i can also give one of you guys ssh access..
    no thanks!
    Why have you got /device/sda1 in the fdisk output ? I have XP installed on 2nd hard drive and extract of fdisk output is as follows ...
    Code:
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1         783     6289416    7  HPFS/NTFS

  9. #9
    Just Joined!
    Join Date
    Feb 2010
    Posts
    7
    Probably because its on the same HD? Linux and windows is both on /dev/sda

  10. #10
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043

    Use Supergrub to fix Windows boot issue then reinstall grub

    Quote Originally Posted by Nasicus View Post
    Probably because its on the same HD? Linux and windows is both on /dev/sda
    So your fdisk output is /dev/sda1 rather than /device/sda1 ...
    In you position I would use Supergrub to restore Windows boot and check if Windows is able to boot ... if it is not use the Windows CD to fix the Windows boot issue and re-install grub using Supergrub after that.
    Last edited by Jonathan183; 02-01-2010 at 09:02 PM. Reason: Add link

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •