Find the answer to your Linux question:
Results 1 to 2 of 2
Ok, i finally got my modem working but there is a few issues that i dont understand......In my attempts i installed this http://www.usrobotics.com/support/pr...asp?prod=5610a , the program on bottom...I guess that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2002
    Posts
    3

    port in use ?'s


    Ok, i finally got my modem working but there is a few issues that i dont understand......In my attempts i installed this http://www.usrobotics.com/support/pr...asp?prod=5610a, the program on bottom...I guess that automatically tries to install it to ttyS3.....upon booting it would say this
    "cannot use port, already in use"
    "/dev/ttys3 no file or directory"

    Ok, so that wasnt working finally used set serial to set it up to ttys1, got online and everything was fine....So i figured that that program isnt doing anything so i just removed it. Then rebooted a little while later and when i tried to use the setserial command again (i understand that i have to do every reboot or find out how to set it up so does automatically on boot), but it said that ttyS3 was in use???? So i installed that program from the USR website and then it would allow me to assign to ttyS3, so my question is, what does that program do?? Obviously the port isnt in use...Also i fould out how to make a ttyS3 and 4 by doing this

    mknod -m 666 /dev/ttyS* c 4 64

    I made a 3 and 4, then tried to set the modem to either one of those and it said port was in use...so does that program enter a command to scan the ports or something?? Im pretty confused, thanks in advance for any help

    BTW: i just noticed that when i made the ttyS3 and 4 i used the wrong number for the minor....should i just delete and remake??? -thanks

  2. #2
    Linux User
    Join Date
    Jul 2002
    Location
    Daytona Beach, FL
    Posts
    487
    not sure what that program is doing but you can add the command to

    /etc/rc.d/rc.local

    to get it done everyime on bootup
    majorwoo

    Quiet brain, or I\'ll stab you with a Q-tip.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •